Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002931 [JEDI VCL] 00 JVCL Components minor random 2005-05-05 06:44 2006-03-30 07:50
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.30 Product Version 3.00
  Target Version Product Build
Summary 0002931: TJvValidateEdit and FStandardFontColor
Description If i set Font.color to my value .. then sometimes (randomly :( ), when I set new value to the JvValidateEdit.Value it change my color to old (in designer set).

in JvValidateEdit.pas there is
on line 1029

  case FCriticalPoints.CheckPoints of
    cpNone:
      Font.Color := FStandardFontColor;

I guess that this is not valid action in my case..

What do you think?
Can I just over jump that situation with some Propery Settings ..?

I can't find where is problem for sure, because during ValidateEdit repainting, it calls JvEdit.pas, JvJCLUtils.pas . ( and they use FOldFontColor ... )

Thanks..
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007111)
anonymous (viewer)
2005-05-05 07:02

In fact the problem is in

jvEdit.pas

line 933

  FIsEmptyValue := (Value = '') and (EmptyValue <> '');
  if not FIsEmptyValue then
  begin
   // Font.Color := FOldFontColor; <- this is problem :(
    inherited Text := Value;
  end


Sorry for bothering ..

I am aware of ValidateEdit component power .. but from my point of view the simplicity of CurrencyEdit should have been kept ..
(0008766)
obones (administrator)
2006-03-30 07:50

This should have been fixed in the latest version.

- Issue History
Date Modified Username Field Change
2005-05-05 06:44 anonymous New Issue
2005-05-05 07:02 anonymous Note Added: 0007111
2006-03-30 07:50 obones Status new => resolved
2006-03-30 07:50 obones Resolution open => fixed
2006-03-30 07:50 obones Assigned To => obones
2006-03-30 07:50 obones Note Added: 0008766


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker