Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002985 [JEDI VCL] 00 JVCL Components tweak always 2005-05-23 08:49 2005-08-22 14:24
Reporter ivan_ra View Status public  
Assigned To obones
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.00
  Target Version Product Build
Summary 0002985: JVCL dirs structure
Description JVCL library has same structure:

JVCL
 \Lib
  \D5
...
  \D9
 \Resources
 \Run

So, source files and units (Dx) are not on the same level. In IDE it is not problem, but when I compile my project from command line and use JVCL\Lib\Dx path in search path, DCC32 can't compile it because it can't find resources:
Error: File not found: '..\Resources\JvDBControls.res'
Error: File not found: '..\Resources\JvDBGrid.res'
...
This is because path to resources from Run and Dx not the same, so, to compile project I must add JVCL\Run to search path or copy "Resources" folder into "Lib"
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007835)
obones (administrator)
2005-08-22 13:36

I'm working on this as we speak, the path informations will be removed from the $R statements
(0007836)
obones (administrator)
2005-08-22 14:24

This is now fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-05-23 08:49 ivan_ra New Issue
2005-08-22 13:36 obones Note Added: 0007835
2005-08-22 13:36 obones Status new => confirmed
2005-08-22 14:24 obones Status confirmed => resolved
2005-08-22 14:24 obones Resolution open => fixed
2005-08-22 14:24 obones Assigned To => obones
2005-08-22 14:24 obones Note Added: 0007836


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker