Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003225 [JEDI VCL] 00 JVCL Components minor always 2005-09-23 03:10 2006-04-04 03:27
Reporter Ramengo View Status public  
Assigned To obones
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.30 Product Version 3.00
  Target Version Product Build
Summary 0003225: TJvDBCalcEdit decimal separator and numeric keyboard
Description When digiting into a TJvDBCalcEdit, it assume that decimal separator must be the same of Windows localization settings. That's correct.
In Italy, for example, we use "," (comma) instead of "." (point).

Unfortunately, the italian numeric keyboard provide a "." (point) as decimal separator. So when digiting into a TJvDBCalcEdit using the numeric keyboard, we have to move to comma in the left part of the keyboard to specify decimals.
That's not correct because the numeric keyboard's point is a decimal separator too. Also it slows the process of data inputing.

Is it possible to change TJvDBCalcEdit in order to accept comma OR numeric keyboard's point as decimal separator ?
Thanks.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008856)
obones (administrator)
2006-04-04 03:27

This is now working in the latest version of the JVCL. Please use it.

- Issue History
Date Modified Username Field Change
2005-09-23 03:10 Ramengo New Issue
2006-04-04 03:27 obones Status new => resolved
2006-04-04 03:27 obones Resolution open => fixed
2006-04-04 03:27 obones Assigned To => obones
2006-04-04 03:27 obones Note Added: 0008856


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker