Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003282 [JEDI VCL] 03 Donations feature N/A 2005-10-21 03:30 2005-10-21 06:30
Reporter DRothmaler View Status public  
Assigned To AHUser
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.00
  Target Version Product Build CVS
Summary 0003282: GetItemAt function for TJvXPBar
Description Hi, I wanted to do some Drag&Drop Stuff with the TJvXPBar, but there are no Drag&Drop Events for the TJvXPBarItems, so I had to do it in the Events of TJvXPBar itself.
But the Problem was to find out which Item was draged...
I needed a function, that gives me back the ItemIndex, for a given (Mouse-)Point.
To do this i took some Lines out of the HookMouseMove function, and put them into an new function called GetItemAt.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files ? file icon JvXPBar.pas.patch [^] (1,779 bytes) 2005-10-21 03:30

- Relationships

-  Notes
(0008049)
AHUser (developer)
2005-10-21 06:30

The patch is now applied to CVS.

- Issue History
Date Modified Username Field Change
2005-10-21 03:30 DRothmaler New Issue
2005-10-21 03:30 DRothmaler File Added: JvXPBar.pas.patch
2005-10-21 06:30 AHUser Status new => resolved
2005-10-21 06:30 AHUser Resolution open => fixed
2005-10-21 06:30 AHUser Assigned To => AHUser
2005-10-21 06:30 AHUser Note Added: 0008049


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker