Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003541 [JEDI VCL] 00 JVCL Components minor always 2006-02-27 09:05 2006-03-10 13:29
Reporter tmstaedt View Status public  
Assigned To AHUser
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.30 Product Version 3.10
  Target Version Product Build
Summary 0003541: JvRequiredFieldsValidator fails, when Control is TJvDateEdit
Description A VarCastError ensues when using JvRequiredFieldsValidator on a TJvDateEdit control.

StackTrace points to:

in System.pas line 8667:
  else if not ChangeSourceAny(Dest, Source, DestType) then
    if VariantChangeTypeEx(Dest, Source, $400, 0, DestType) <> 0 then
==> VarCastError;
  end;
Steps To Reproduce
Additional Information Workaround: Use TJvCustomValidator and check if Date is 0 in the OnValidate Event.
Tags No tags attached.
Attached Files zip file icon JvRequiredFieldValidatorBug.zip [^] (5,090 bytes) 2006-03-10 05:27

- Relationships

-  Notes
(0008652)
AHUser (developer)
2006-03-10 05:01

I cannot reproduce this. Please attach a simple example that shows the bug.
(0008653)
tmstaedt (reporter)
2006-03-10 05:27

here it comes. I am using Delphi 5, Update pack 1, the jedi jvcl is 3.1 according to the AboutJVCL property, but it's from a just downloaded version which claims to be 3.20. The bug, though, was in 3.0 as well.
(0008654)
AHUser (developer)
2006-03-10 13:29

Fixed in CVS. I have also added "support" for numeric values like Integer, Double and Boolean. For numeric and boolean values the validation will always pass because zero/false is a valid value.

- Issue History
Date Modified Username Field Change
2006-02-27 09:05 tmstaedt New Issue
2006-03-10 05:01 AHUser Note Added: 0008652
2006-03-10 05:01 AHUser Status new => feedback
2006-03-10 05:27 tmstaedt File Added: JvRequiredFieldValidatorBug.zip
2006-03-10 05:27 tmstaedt Note Added: 0008653
2006-03-10 13:29 AHUser Status feedback => resolved
2006-03-10 13:29 AHUser Resolution open => fixed
2006-03-10 13:29 AHUser Assigned To => AHUser
2006-03-10 13:29 AHUser Note Added: 0008654


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker