Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004733 [JEDI VCL] 00 JVCL Components minor always 2009-04-06 16:12 2009-04-29 15:27
Reporter gpcaretti View Status public  
Assigned To obones
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.37 Product Version 3.36
  Target Version Product Build
Summary 0004733: TJvDesignSurface: Ctrl-Left/Right/Up/Down and Shift-Left/Right/Up/Down on Windows
Description With D2007 the Ctrl-Left/Right/Up/Down and Shift-Left/Right/Up/Down do not work on the design panel (TJvDesignSurface) when is in active mode because the panel does not intercept the "Special Keys" during the WM_KEYDOWN (VK_LEFT, VK_RIGHT,
etc.).
Steps To Reproduce
Additional Information In D2007 the message management loop calls the IsKeyMsg method. IsKeyMsg
does not pass on the original key message, but it adds an offset (CN_BASE) to
the message ID to turn the original Windows message into a VCL message.
So, WM_KEYDOWN becomes CN_KEYDOWN, WM_CHAR becomes CN_CHAR, and so on.

For this reason, in order to intercept the special keys the CN_KEYDOWN
and CN_KEYUP should be checked in the JvDesignSurface unit.

Please, find attached the proposed patch I added to the above unit officially released in JVCL 3.36 (look for GpCaretti)
Tags No tags attached.
Attached Files ? file icon JvDesignSurface.pas [^] (30,785 bytes) 2009-04-06 16:12

- Relationships

-  Notes
(0015477)
obones (administrator)
2009-04-29 15:27

Thanks, this is now in SVN.

- Issue History
Date Modified Username Field Change
2009-04-06 16:12 gpcaretti New Issue
2009-04-06 16:12 gpcaretti File Added: JvDesignSurface.pas
2009-04-06 16:12 gpcaretti Issue Monitored: gpcaretti
2009-04-29 15:27 obones Note Added: 0015477
2009-04-29 15:27 obones Status new => resolved
2009-04-29 15:27 obones Fixed in Version => Daily / SVN
2009-04-29 15:27 obones Resolution open => fixed
2009-04-29 15:27 obones Assigned To => obones
2009-04-29 15:37 gpcaretti Issue End Monitor: gpcaretti


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker