Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005542 [JEDI VCL] 00 JVCL Components major always 2011-04-03 11:12 2012-09-10 14:15
Reporter lr83 View Status public  
Assigned To obones
Priority normal Resolution duplicate Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version 3.46 Product Version Daily / GIT
  Target Version Product Build
Summary 0005542: [TJvBalloonHint] Problem with long hint on vista
Description When the total size of the text of the hint is over about 100 characters (even if the text is over several line), the hint doesn't appear correctly.
See the image below i made on a test program. When i click on the button, i fill the hint with a long text and we can see that the hint doesn't appear correctly.
The component use all the default property except UseBalloonAsApplicationHint set to true.
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files jpg file icon Hint_Bug.jpg [^] (156,117 bytes) 2011-04-03 11:12
zip file icon Hint_bug_source.zip [^] (7,365 bytes) 2011-06-07 19:50

- Relationships
duplicate of 0005258resolvedobones TJvBalloonHint NOT painting on Windows 7 

-  Notes
(0018618)
obones (administrator)
2011-06-07 17:50

Please provide the zipped sources of a sample application showing this
(0018645)
lr83 (reporter)
2011-06-07 19:52

I am under Windows Vista and i use D2010
See source of the sample test application
(0018692)
obones (administrator)
2011-06-08 16:25

I have no such problem with latest SVN content, Delphi XE and Windows Seven.
(0018697)
lr83 (reporter)
2011-06-08 16:55

And with Windows Vista ?
Note : if i don't check the checkbox property "use the execution theme" in the project property, i also have no problem.
(0018810)
lr83 (reporter)
2011-07-01 15:43

After a long debug process, i found a solution of my problem. In the procedure line 959 :
procedure TJvBalloonWindow.CreateParams(var Params: TCreateParams);

I put in comment the 2 lines :
      if not IsWinSeven_UP and IsWinVista_UP and ThemeServices.ThemesEnabled then
        ExStyle := ExStyle or WS_EX_LAYERED;

With this, no more problems !
(0018931)
obones (administrator)
2011-09-21 11:51

So this means that a fix for Vista only that was added earlier on is no longer needed?
(0018983)
lr83 (reporter)
2011-09-26 10:51

Probably !
(0019490)
obones (administrator)
2012-02-23 10:04

Fixed by 0005258

- Issue History
Date Modified Username Field Change
2011-04-03 11:12 lr83 New Issue
2011-04-03 11:12 lr83 File Added: Hint_Bug.jpg
2011-06-07 17:50 obones Note Added: 0018618
2011-06-07 17:50 obones Status new => feedback
2011-06-07 19:50 lr83 File Added: Hint_bug_source.zip
2011-06-07 19:52 lr83 Note Added: 0018645
2011-06-08 10:12 obones Status feedback => acknowledged
2011-06-08 16:25 obones Note Added: 0018692
2011-06-08 16:25 obones Status acknowledged => feedback
2011-06-08 16:55 lr83 Note Added: 0018697
2011-07-01 15:43 lr83 Note Added: 0018810
2011-09-21 11:51 obones Note Added: 0018931
2011-09-26 10:51 lr83 Note Added: 0018983
2011-09-26 17:04 obones Relationship added related to 0005258
2011-10-07 16:12 obones Status feedback => confirmed
2012-02-23 10:04 obones Note Added: 0019490
2012-02-23 10:04 obones Relationship replaced duplicate of 0005258
2012-02-23 10:04 obones Duplicate ID 0 => 5258
2012-02-23 10:04 obones Status confirmed => resolved
2012-02-23 10:04 obones Fixed in Version => Daily / SVN
2012-02-23 10:04 obones Resolution open => duplicate
2012-02-23 10:04 obones Assigned To => obones
2012-09-10 14:15 obones Fixed in Version Daily / SVN => 3.46


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker