Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006463 [JEDI VCL] 00 JVCL Components minor always 2015-10-23 15:26 2018-08-30 14:12
Reporter Gerold View Status public  
Assigned To obones
Priority normal Resolution no change required Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version Daily / GIT
  Target Version Product Build
Summary 0006463: HTTPS support in TJvHttpUrlGrabber
Description I guess there is one error in class function TJvHttpsUrlGrabber.CanGrab.

class function TJvHttpsUrlGrabber.CanGrab(const Url: string): Boolean;
begin
  Result := LowerCase(Copy(Url, 1, 7)) = cHTTPsPrefix;
end;

cHTTPsPrefix has a length of 8 characters. So the function will always return false. Should be:

Result := LowerCase(Copy(Url, 1, 8)) = cHTTPsPrefix;

But even if I change it, it does not download.


Steps To Reproduce
Additional Information Daily: 2015-10-21
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021482)
obones (administrator)
2018-07-18 15:38

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021570)
Gerold (reporter)
2018-08-03 10:20

Solved

- Issue History
Date Modified Username Field Change
2015-10-23 15:26 Gerold New Issue
2018-07-18 15:38 obones Note Added: 0021482
2018-07-18 15:38 obones Status new => feedback
2018-08-03 10:20 Gerold Note Added: 0021570
2018-08-30 14:12 obones Status feedback => resolved
2018-08-30 14:12 obones Resolution open => no change required
2018-08-30 14:12 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker