Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006504 [JEDI VCL] 00 JVCL Components minor always 2016-03-31 10:43 2019-05-02 08:33
Reporter DanielTr View Status public  
Assigned To jfudickar
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.48
  Target Version Product Build
Summary 0006504: Width of UpDown buttons in TJvCustomSpinEdit does not scale
Description The buttons width is calculated as the systems scrollbar width but limited to 15px (hard coded) in JvSpin.DefBtnWidth. This applies to bkClassic and bkStandard.

This way the buttons become very narrow, when using a higher scale factor or an output device with high dpi.

Suggestions for a solution:
1. Remove the limitation in DefBtnWidth completely (except there is a use case where it is really necessary)
2. Make the limitation value variable with public/protected getter and setter and 15 as default value
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021490)
obones (administrator)
2018-07-18 15:42

High DPI support is very poor in the VCL itself, so it's hard to make it work in the JVCL.
That being said, could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021644)
mh (reporter)
2019-03-11 22:54

Is there a need for the 15 px limit?
(0021648)
mh (reporter)
2019-03-12 22:38

Another suggestion for this: make 15px for 96 dpi and automaticaly scale the limit according to screen dpi? What to do in multi display scenarios? Use the dpi of the screen the control is on?
(0021722)
jfudickar (developer)
2019-04-19 21:30

Yes and yes :-)
(0021732)
mh (reporter)
2019-04-24 19:56

I just created a pull request for a possible solution. I hope it is good enough.
(0021784)
mh (reporter)
2019-05-01 10:08

New improved pull request created:
https://github.com/project-jedi/jvcl/pull/113 [^]
(0021791)
jfudickar (developer)
2019-05-02 08:33

Fixed in Repository

- Issue History
Date Modified Username Field Change
2016-03-31 10:43 DanielTr New Issue
2018-07-18 15:42 obones Note Added: 0021490
2018-07-18 15:42 obones Status new => feedback
2019-03-11 22:54 mh Note Added: 0021644
2019-03-12 22:38 mh Note Added: 0021648
2019-04-19 21:30 jfudickar Note Added: 0021722
2019-04-24 19:56 mh Note Added: 0021732
2019-05-01 10:08 mh Note Added: 0021784
2019-05-02 08:33 jfudickar Note Added: 0021791
2019-05-02 08:33 jfudickar Status feedback => resolved
2019-05-02 08:33 jfudickar Resolution open => fixed
2019-05-02 08:33 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker