Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006513 [JEDI VCL] 02 Installation major always 2016-05-17 23:51 2016-08-03 21:25
Reporter Xavi View Status public  
Assigned To AHUser
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.48
  Target Version Product Build
Summary 0006513: unable to install into delphi 10.1 berlin
Description I can't install jcl/jvcl in Delphi 10.1 Berlin, due to an unsupported delphi version. when we will be able to download the supported version?
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021293)
thomasvoelker (reporter)
2016-06-14 17:36

Managed to install JCL 2.7.0.5676 on Delphi Berlin 10.1 with the following changes:

source\windows\JclICL.pas: Compile error @ line 674, incompatible types. Changed DumpIL(Options: ... to DumpIL(Options_: ... at line 200, 619 and 674.

source\common\JclIDEUtils.pas:
changed line 89 to: SupportedDelphiVersions = [5, 6, 7, 8, 9, 10, 11, 12, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24];

changed line 943 to: Supported: True),
added @ line 944:
    (
      Name: @RsRSName;
      VersionStr: '10.1';
      DCCVersion: 31.0;
      IDEPkgVersion: 24;
      PkgVersion: 24;
      CoreIdeVersion: '240';
      Supported: True)

source\install\JclIDEUtils.pas:
changed line 3300 to: or (Target.VersionNumber in [3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 14, 15, 16, 17, 18]);

then I copied:
packages\d23 ==> packages\d24 (directory)
JclPackagesD230.groupproj ==> JclPackagesD240.groupproj (file, still referenced d23-contents, so first step might not be necessary)
lib/d23 ==> lib/d24

After that the installer complained that bcc32.exe could not be found - which is right because I only have delphi. the installer itself issued in the log, it also had found c++ builder 32bit. So I took a look on the detection routines and found that HKLM\Software\WOW6432Node\Embarcadero\BDS\18.0\Personalities also listet BCB and also HKCU\Software\Embarcadero\BDS\18.0\Personalities did. I deleted both Keys and the installation succeeded.
(0021295)
GroePaZ (reporter)
2016-06-24 17:44

Hi Thomas,
I can install JCL now with your help, but not the JVCL. Can you or anybody send me the changes on the files for JVCL?
(0021296)
GroePaZ (reporter)
2016-06-24 18:09

Problem is, that JVCLInstaller does'nt recognizes Delphi 10.1. Berlin, only XE7 and older. Compiling JVCLInstaller fails because missing Jedi\Jedi.inc and further errors.
(0021297)
GroePaZ (reporter)
2016-06-25 13:52

I have now changed JVCLInstaller to recognize Delphi 10.1. Berlin, but compiling JVCore ends immediately with errors (JVCore must recompile,...).
Compiling project JVCore about Delphi end with syntax errors :-(
Any ideas?
(0021318)
AHUser (developer)
2016-08-03 21:25

JCL 2.7.0.5676 is from 2015. No wonder it doesn't know a Delphi version from 2016.

Current JCL source:
https://github.com/project-jedi/jcl [^]

Current JVCL source:
https://github.com/project-jedi/jvcl [^]

- Issue History
Date Modified Username Field Change
2016-05-17 23:51 Xavi New Issue
2016-06-14 17:36 thomasvoelker Note Added: 0021293
2016-06-24 17:44 GroePaZ Note Added: 0021295
2016-06-24 18:09 GroePaZ Note Added: 0021296
2016-06-25 13:52 GroePaZ Note Added: 0021297
2016-08-03 21:25 AHUser Note Added: 0021318
2016-08-03 21:25 AHUser Status new => resolved
2016-08-03 21:25 AHUser Resolution open => fixed
2016-08-03 21:25 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker