Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006527 [JEDI VCL] 00 JVCL Components major always 2016-09-27 10:51 2019-05-02 08:33
Reporter tas View Status public  
Assigned To jfudickar
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version Daily / GIT
  Target Version Product Build
Summary 0006527: TJvHTMLParser
Description Doesn't parse correct.

This is html example text:

<body>Paragraph</body>


The problem occurs when tags starting with the same symbol and one of them have length 1 (for example tag )
Steps To Reproduce
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021400)
tas (reporter)
2016-09-27 10:56

Example html text:

<'body'><'b'>Paragraph<'/b'><'/body'>


The problem occurs when tags starting with the same symbol and one of them have length 1 (for example tag 'b')
(0021401)
tas (reporter)
2016-09-27 14:20

fixed:

change
  J := StrFind(StartTag1, Str, J);

to

  if trim(StartTag2) = '' then
    J := StrFind(StartTag1, Str, J)
  else
  begin
    J1 := J;
    J := StrFind(StartTag1 + ' ', Str, J);
    if J = 0 then
    begin
     J := J1;
     J := StrFind(StartTag1 + '>', Str, J);
    end;
  end;
(0021497)
obones (administrator)
2018-07-18 15:45

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021774)
mh (reporter)
2019-04-28 10:59

Pull request created:
https://github.com/project-jedi/jvcl/pull/108 [^]
(0021781)
mh (reporter)
2019-04-30 21:52

Pull request superceeded by
https://github.com/project-jedi/jvcl/pull/112 [^]
(0021792)
jfudickar (developer)
2019-05-02 08:33

Fixed in Repository

- Issue History
Date Modified Username Field Change
2016-09-27 10:51 tas New Issue
2016-09-27 10:53 tas Issue Monitored: tas
2016-09-27 10:53 tas Issue End Monitor: tas
2016-09-27 10:56 tas Note Added: 0021400
2016-09-27 14:20 tas Note Added: 0021401
2018-07-18 15:45 obones Note Added: 0021497
2018-07-18 15:45 obones Status new => feedback
2019-04-28 10:59 mh Note Added: 0021774
2019-04-30 21:52 mh Note Added: 0021781
2019-05-02 08:33 jfudickar Note Added: 0021792
2019-05-02 08:33 jfudickar Status feedback => resolved
2019-05-02 08:33 jfudickar Resolution open => fixed
2019-05-02 08:33 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker