View Issue Details

IDProjectCategoryView StatusLast Update
0004386JEDI VCL04 Feature Requestpublic2008-10-25 07:34
ReportersnwAssigned ToAHUser 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.36 
Summary0004386: add Periodical property to TJvTrayIcon component
DescriptionTJvTrayIcon = class(TJvComponent)
  private
    FDirection : integer;
    FPeriodical : boolean;
  published
property Periodical : boolean read FPeriodical write FPeriodical;


procedure TJvTrayIcon.DoAnimation;
begin
  if (tisTrayIconVisible in FState) and (FIcons <> nil) and (FIcons.Count >
0) then
  begin
    if IconIndex < 0 then
      IconIndex := 0
    else
    if FPeriodical then
      begin
      if IconIndex=(FIcons.Count-1) then
         FDirection:=-1
      else
         if IconIndex=0 then
            FDirection:=1;
      IconIndex := (IconIndex + FDirection) mod FIcons.Count;
      end
    else IconIndex := (IconIndex + 1) mod FIcons.Count;
    if Assigned(FOnAnimate) then
      FOnAnimate(Self, IconIndex);
  end;
end;
Additional Informationthis code change enables TJvTrayIcon to animate images forward and backward
periodically, so one doesnt have to load (n-1) images twice
(eg it was img1,img2,img3,img2,img1 in imagelist, now only img1,img2 and
img3)
TagsNo tags attached.

Activities

obones

2008-07-15 01:08

administrator   ~0014380

Periodical is too broad a name. The period could be one every two image, or all backward. Please suggest another name.

jfudickar

2008-07-15 15:02

developer   ~0014382

What about AutoRotate?

Greetings
Jens

snw

2008-07-16 03:52

reporter   ~0014384

for me Periodical is fine, sinus is a periodical function right ?
how about CyclicRotate, CyclicAnimation. whatever :)

obones

2008-07-16 06:02

administrator   ~0014385

yes, sine is periodical, so is square, triangle, cosine. But they are different, hence their different names.
AutoRotate suggests to me that it's the image that rotates not the animation.
What we have here, is more like "Back and Forth" but I'm no too happy with this either. And we should have a enumeration rather than a "boolean" property, just in case.

AHUser

2008-10-25 07:33

developer   ~0014903

Added to SVN as "SwingForthAndBack: Boolean"

Issue History

Date Modified Username Field Change
2008-07-01 09:10 snw New Issue
2008-07-15 01:08 obones Note Added: 0014380
2008-07-15 01:08 obones Status new => acknowledged
2008-07-15 15:02 jfudickar Note Added: 0014382
2008-07-16 03:52 snw Note Added: 0014384
2008-07-16 06:02 obones Note Added: 0014385
2008-10-25 07:33 AHUser Status acknowledged => resolved
2008-10-25 07:33 AHUser Fixed in Version => Daily / SVN
2008-10-25 07:33 AHUser Resolution open => fixed
2008-10-25 07:33 AHUser Assigned To => AHUser
2008-10-25 07:33 AHUser Note Added: 0014903