Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006545 [JEDI VCL] 00 JVCL Components minor always 2017-02-12 15:39 2019-05-02 08:33
Reporter mksjgj View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0006545: TJvInterpreterProgram does not support scientific notation
Description TJvInterpreterProgram can not handle express with scientific notation, i.e.:

1.2e2+1

 
Additional Information please check the attachment for modification, marked by //lht
Tags No tags attached.
Attached Files zip file icon bug.zip [^] (7,820 bytes) 2017-02-12 15:39
zip file icon Test1.zip [^] (57,896 bytes) 2018-07-19 04:21

- Relationships

-  Notes
(0021519)
obones (administrator)
2018-07-18 15:51

Could you check if the issue is still present in the latest GIT content? If yes, please provide the zipped sources of an application showing this.
(0021561)
mksjgj (reporter)
2018-07-19 04:22

i can not see any modification for this issue, so the bug is still here.
(0021743)
mh (reporter)
2019-04-25 22:25

Ok, bug.zip contains a modified version of the relevant JVCL unit. If I find the time I might implement the suggestions and create a pull request for this.
(0021748)
mh (reporter)
2019-04-26 18:13

Added pull request for this based on file modifications in bug.zip:
https://github.com/project-jedi/jvcl/pull/93 [^]
(0021786)
mh (reporter)
2019-05-01 13:44

Revoked pull request 0000093 due to some formatting and naming issues and replaced it by this one:
https://github.com/project-jedi/jvcl/pull/115 [^]
(0021790)
jfudickar (developer)
2019-05-02 08:33

Fixed in Repository

- Issue History
Date Modified Username Field Change
2017-02-12 15:39 mksjgj New Issue
2017-02-12 15:39 mksjgj File Added: bug.zip
2017-02-12 15:43 mksjgj Issue Monitored: mksjgj
2018-07-18 15:51 obones Note Added: 0021519
2018-07-18 15:51 obones Status new => feedback
2018-07-19 04:21 mksjgj File Added: Test1.zip
2018-07-19 04:22 mksjgj Note Added: 0021561
2019-04-25 22:25 mh Note Added: 0021743
2019-04-26 18:13 mh Note Added: 0021748
2019-05-01 13:44 mh Note Added: 0021786
2019-05-02 08:33 jfudickar Note Added: 0021790
2019-05-02 08:33 jfudickar Status feedback => resolved
2019-05-02 08:33 jfudickar Resolution open => fixed
2019-05-02 08:33 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker