Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001491 [JEDI VCL] 00 JVCL Components crash always 2004-03-18 04:42 2004-10-05 11:27
Reporter Dierk View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001491: TJvChangeNotify crashes on deactivating in onChange event
Description procedure TMainform.JvChangeNotify1Notifications0Change(Sender: TObject);
begin
  JvChangeNotify1.active:=false; //<--This crashes the application

  ..... do something timeintensive
        and knowing for shure that same event can´t occure
        in this moment

  JvChangeNotify1.active:=true;

end;

Greetings

Dierk
Additional Information
Tags No tags attached.
Attached Files zip file icon JvChangeNotify.zip [^] (3,664 bytes) 2004-03-18 06:14

- Relationships
related to 0002052resolveduser72 TJvChangeNotify.Active := False blocks System 

-  Notes
(0003376)
user72
2004-03-18 06:13

No wonder either. You are effectively killing the thread from an event called by the thread. Not so good :)

I think the attached unit resolves the issue, though, but I don't know how stable it is. Please try it out and let me know if it works.
(0003378)
Dierk (reporter)
2004-03-18 07:01

Peter,
now it works stable.....
(0003383)
user72
2004-03-18 14:21

Updated in CVS
(0005197)
remkobonte (developer)
2004-09-06 09:51

Bug is reintroduced in Rev. 1.29
(0005260)
user72
2004-09-25 01:34

I've added a FreeOnTerminate:boolean to the component. Basically, if you want to change Active in the OnChangeNotify event, set it to true.
(0005316)
user72
2004-10-05 11:27

Since there is no reply, I am assuming this now works

- Issue History
Date Modified Username Field Change
2004-03-18 04:42 Dierk New Issue
2004-03-18 06:13 user72 Note Added: 0003376
2004-03-18 06:13 user72 Assigned To => user72
2004-03-18 06:13 user72 Status new => assigned
2004-03-18 06:13 user72 Description Updated
2004-03-18 06:14 user72 File Added: JvChangeNotify.zip
2004-03-18 06:14 user72 Issue Monitored: user72
2004-03-18 07:01 Dierk Note Added: 0003378
2004-03-18 14:21 user72 Status assigned => resolved
2004-03-18 14:21 user72 Resolution open => fixed
2004-03-18 14:21 user72 Note Added: 0003383
2004-09-06 09:51 remkobonte Status resolved => feedback
2004-09-06 09:51 remkobonte Resolution fixed => reopened
2004-09-06 09:51 remkobonte Note Added: 0005197
2004-09-07 11:32 user72 Assigned To user72 =>
2004-09-25 01:34 user72 Note Added: 0005260
2004-09-25 02:16 user72 Relationship added related to 0002052
2004-10-05 11:27 user72 Status feedback => resolved
2004-10-05 11:27 user72 Resolution reopened => fixed
2004-10-05 11:27 user72 Assigned To => user72
2004-10-05 11:27 user72 Note Added: 0005316


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker