Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001617 [JEDI VCL] 00 JVCL Components feature always 2004-04-10 07:08 2004-04-30 02:24
Reporter Markus Spoettl View Status public  
Assigned To marcelb
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001617: JvInspector, opening categories using the keyboard
Description Is there a way to open category items using the keyboard. I had a look at the code, apparently you're using "VK_ADD" and "VK_SUBTRACT". however, if used on a notebook this isn't very handy. Would it be possible to add <ENTER> or <SPACE> as toggle key or left-right keys? VS.NET uses left-right and enter.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003810)
marcelb (manager)
2004-04-11 11:35

OK, thought about it. I know I mentioned to you (in a private mail) that left/right would be impossible, but that is not true, at least not for normal items.

The problem is that I want to always have the same keys for the same purpose. Since each item technically could have sub items, I can't use left/right. Enter and Space can even be problematic (Enter is used to apply a value and space can be used in typing a value).

What to do, what to do?
(0004135)
marcelb (manager)
2004-04-30 02:15

Decided on using ctrl+left/right and ctrl+enter. Only a slight deviation from VS.NET usage, but can at least be consistently used in JvInspector. Will implement today.
(0004136)
marcelb (manager)
2004-04-30 02:24

Fixed in CVS rev 1.90

- Issue History
Date Modified Username Field Change
2004-04-10 07:08 Markus Spoettl New Issue
2004-04-10 07:23 marcelb Status new => acknowledged
2004-04-11 11:32 marcelb Status acknowledged => assigned
2004-04-11 11:32 marcelb Assigned To => marcelb
2004-04-11 11:35 marcelb Note Added: 0003810
2004-04-30 02:15 marcelb Note Added: 0004135
2004-04-30 02:24 marcelb Status assigned => resolved
2004-04-30 02:24 marcelb Resolution open => fixed
2004-04-30 02:24 marcelb Note Added: 0004136


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker