Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001629 [JEDI VCL] 00 JVCL Components feature always 2004-04-12 10:34 2005-01-02 05:22
Reporter anonymous View Status public  
Assigned To Aleksey Kudinov
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001629: TJvWizardRouteMapSteps - navigators doesn't fire OnNext event
Description If Navigators are shown and the user clicks on them they should fire OnNextButtonClick, OnBackButtonClick, AND OnSelectNextPage, OnSelectNextPage

That is important because I know that I'm not the only one who is using OnSelectNextPage and OnSelectNextPage to allow user to change current page.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003823)
AHUser (developer)
2004-04-12 15:25

For OnSelectNextPage and OnSelectPriorPage I can test the new PageIndex for one above and one below and then call the SelectNextPage/SelectPriorPage methods.
(Added to CVS)

I think the OnNextButtonClick and OnBackButtonClick events are not the correct one for the WizardRouteMap controls because the "Next Button" and the "Back Button" are clearly defined to be the one on the bottom bar.
(0004066)
AHUser (developer)
2004-04-25 07:54

Fixed in CVS
(0005899)
anonymous (viewer)
2004-12-16 13:57

just do it!
(0005962)
obones (administrator)
2004-12-20 07:11

Please test with the latest CVS version from here:

http://jvcl.sf.net/daily/ [^]

If we don't get any feedback from you in the next 7 days, we will considered this issue fixed

- Issue History
Date Modified Username Field Change
2004-04-12 10:34 anonymous New Issue
2004-04-12 15:25 AHUser Note Added: 0003823
2004-04-25 07:54 AHUser Status new => resolved
2004-04-25 07:54 AHUser Resolution open => fixed
2004-04-25 07:54 AHUser Assigned To => AHUser
2004-04-25 07:54 AHUser Note Added: 0004066
2004-12-16 13:57 anonymous Status resolved => feedback
2004-12-16 13:57 anonymous Resolution fixed => reopened
2004-12-16 13:57 anonymous Note Added: 0005899
2004-12-16 13:57 anonymous Assigned To AHUser => Aleksey Kudinov
2004-12-20 07:11 obones Note Added: 0005962
2005-01-02 05:22 AHUser Status feedback => resolved
2005-01-02 05:22 AHUser Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker