Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001647 [JEDI VCL] 04 Feature Request minor always 2004-04-15 12:11 2004-04-28 09:28
Reporter Markus Spoettl View Status public  
Assigned To marcelb
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001647: JvInspectorColorItem: List height fix proposal/question
Description I finally fixed the item list painting issue (list not being a multiple of item height) in ColorItem, it requires a change in TJvCustomInspectorItem.DropDown as follows:

    if TListBox(ListBox).IntegralHeight then
    begin
      ListBox.Canvas.Font := TListBox(ListBox).Font;
// change begin (declare _h: Integer; somewhere)
      _h := CanvasMaxTextHeight(ListBox.Canvas);
      DoMeasureListItem(ListBox, -1, _h);
      TListBox(ListBox).ItemHeight := _h;
// change end
    end;

The problem is that

// oldcode begin
    TListBox(ListBox).ItemHeight := CanvasMaxTextHeight(ListBox.Canvas);
// oldcode end

will return a value that is too small for color items.

Additionally, you need to remove iifOwnerDrawListVariable in TJvInspectorColorItem.SetFlags()

like:

    inherited SetFlags(Value + [iifValueList,
                                iifAllowNonListValues,
                                iifOwnerDrawListFixed]
                             - [iifOwnerDrawListVariable]);


I'm aware of the fact that calling DoMeasureListItem(x, -1, _h) might be a problem, but I don't know a better way to do it.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004115)
marcelb (manager)
2004-04-28 09:14

Fixed TJvCustomInspectorItem.DropDown in CVS rev 1.87
(0004116)
marcelb (manager)
2004-04-28 09:28

Fixed in JvInspExtraEditors 1.15 (including the problem with the not rendering color names in a drop down).

- Issue History
Date Modified Username Field Change
2004-04-15 12:11 Markus Spoettl New Issue
2004-04-15 12:37 marcelb Assigned To => marcelb
2004-04-15 12:37 marcelb Status new => acknowledged
2004-04-15 12:37 marcelb Category 00 JVCL Components => 04 Feature Request
2004-04-28 09:14 marcelb Note Added: 0004115
2004-04-28 09:28 marcelb Status acknowledged => resolved
2004-04-28 09:28 marcelb Resolution open => fixed
2004-04-28 09:28 marcelb Note Added: 0004116


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker