Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001680 [JEDI VCL] 00 JVCL Components feature always 2004-04-21 17:02 2004-04-24 12:55
Reporter Curthalion View Status public  
Assigned To user72
Priority normal Resolution no change required  
Status resolved   Product Version
Summary 0001680: D7:W98SE Installation completes but packages won't load.
Description On 18th April 2004 I downloaded the full Beta 3 zip from Sourceforge:

Source file: JVCL300BETA1JCL190Complete.zip

With such a large component set to install I reinstalled the whole of Delphi 7 Professional first. The only coustomization I made was to change the BPL/DCP output directories from Projects\BPL to a new folder pair, MyObjects\BPL and MyObjects\DCP in the Delphi7 directory. I then unzipped JCL and JVCL into a directory, MyObjects\JEDI, and ran the file, jvcl\install.bat.

I selected all the packages in the list and set the checkboxes for [Install JCL], [JVCL Developer Installation], [Clean JVCL component palettes], [Register global design editors], and [Use JvGIF].
I then ran the INSTALL command, which completed successfully with only 5 warnings in a couple of packages about unused variables.

When I then ran Delphi7, however, none of the packages would load. Even trying to select any of them in brings up the following error message:

Can't load package C:\Program Files\Borland\Delphi7\MyObjects\BPL\JvAppFrmD7D.bpl.
One of the library files needed to run this application cannot be found.

I noticed that none of the JCL packages were listed in the package editor, and that the foilder, \jcl\lib\d7\obj, doesn't exist, so I both changed the library path to read \jcl\lib\d7, and created the d7\obj folder and copied the contents of li\d7 there as well. I then unistalled and tried again but with same result.

My question is, if there actually is a file missing, how do I find out which one, or if my path variables are incorrect, what should they be?

Library paths:
$(DELPHI)\MYOBJECTS\JEDI\jcl\lib\d7\obj (corrected to ...lib\d7)
$(DELPHI)\MYOBJECTS\JEDI\JVCL\common
$(DELPHI)\MYOBJECTS\JEDI\JVCL\run
$(DELPHI)\MYOBJECTS\JEDI\JVCL\design

BPL Output directory
C:\Program Files\Borland\Delphi7\MyObjects\BPL

DCP output directory
C:\Program Files\Borland\Delphi7\MyObjects\DCP

Browsing path
$(DELPHI)\MYOBJECTS\JEDI\jcl\source\common
$(DELPHI)\MYOBJECTS\JEDI\jcl\source\vcl
$(DELPHI)\MYOBJECTS\JEDI\jcl\source\visclx
$(DELPHI)\MYOBJECTS\JEDI\jcl\source\windows
$(DELPHI)\MYOBJECTS\JEDI\JVCL\run
$(DELPHI)\MYOBJECTS\JEDI\JVCL\design
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0003982)
user72
2004-04-21 23:49

You need to add the bpl output folder to your SYSTEM path as well. I don't remember how that is done in Win98 but in other OS'es, you right-click the "My Computer" icon, select "Properties" from the menu and then you should find the environment variables on one of the tabs in the dialog.

Try this first and if still doesn't work, post again
(0003990)
AHUser (developer)
2004-04-22 00:54
edited on: 2004-04-22 00:55

Under Win98 you must edit the Autoexec.bat and add the following line

SET PATH=%PATH%;C:\Program Files\Borland\Delphi7\MyObjects\BPL


The JCL packages are not installed because the JVCL Installer is no JCL Installer. It only compiles the files it requires. And these files are only the runtime packages and dcp files.

The Installer in the BETA 1 pack is obsolute. The new installer (only in daily snapshots and CVS) starts the JCL Installer for JCL installation.

bearbeitet am: 04-22-04 00:55
(0004009)
Curthalion (reporter)
2004-04-22 08:14

peter3 and AHUser:
Thanks very much for your suggestions.

My system path was already set for MyObjects\BPL (I learnt that one a long time ago) and I've downloaded the latest JCL from CVS, but the result's the same: Installers compile both JCL and JVCL and then Delphi won't load them.
(0004025)
user72
2004-04-22 23:54

Sorry, I don't have any additional suggestions. Maybe Andreas can come up with something?
(0004027)
AHUser (developer)
2004-04-23 02:00

> Maybe Andreas can come up with something

Unfortunatelly not. I don't know why it does not work. The .bpl files are there. So the installer had done it's job.
Maybe removing all packages (not uncheck, remove) from the packages list, restarting Delphi and adding the JVCL packages (.bpl) by hand works.

Here the require list for JvAppFrmD7D.bpl:
 - DesignIde70.bpl
 - DJcl70.bpl
 - DJclVcl70.bpl
 - JvAppFrmD7R.bpl
 - JvCoreD7R.bpl
 - JvStdCtrlsD7R.bpl
 - Kernel32.dll
 - Rtl70.bpl
 - Vcl70.bpl
 - VclJpg70.bpl
 - Vclx70.bpl
(0004028)
user72
2004-04-23 02:41

YOu might want to check the registry (\Software\Borland\Delphi\7.0\Known Packages) in HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE and verify that the JVCL packages are present and have the correct path(s).
(0004046)
anonymous (viewer)
2004-04-24 01:27

peter3 and AHUser
Thank you for your continuing efforts to resolve this problem.

I have decided to uninstall everything (Delphi included), clean out AUTOEXEC.BAT and the registry (ie. restore my backup copies), and try a clean install using the JCL+JVCL210FullInstall.zip pack. I'm assuming that this stable version will install without any problems that haven't all long since been resolved. Once that is working I shall save an image of the system, start again with with Beta3 and see how they compare. Of course, if it still doesn't work, then I'll know there's either something very wrong with my Windows installation, or it was me doing something incredibly stupid all along.

One passing thought that just hit me: shouldn't the checkbox, 'Build with run-time packages' in the 'Install, packages...' dialog, be checked? By default this option is off in Delphi installations, although I'm not sure how this would affect loading the IDE at the beginning of a session.
(0004056)
Curthalion (reporter)
2004-04-24 05:53

This problem has now been resolved.

Whatever the problem was it lay somewhere either in my customisation of the Delphi7 IDE or in that I had CBuilder 3 and Interbase 6.5 installed as well.

I suspect the fault lay in the default Interbase istallation, but there probably needs to be a general warning put out about changing default library paths in Delphi 7.

My thanks to peter3 and AHUser for their help in addressing this problem.
(0004059)
user72
2004-04-24 12:55

You are welcome

- Issue History
Date Modified Username Field Change
2004-04-21 17:02 Curthalion New Issue
2004-04-21 23:49 user72 Note Added: 0003982
2004-04-22 00:04 user72 Status new => feedback
2004-04-22 00:54 AHUser Note Added: 0003990
2004-04-22 00:55 AHUser Note Edited: 0003990
2004-04-22 08:14 Curthalion Note Added: 0004009
2004-04-22 23:54 user72 Note Added: 0004025
2004-04-23 02:00 AHUser Note Added: 0004027
2004-04-23 02:41 user72 Note Added: 0004028
2004-04-24 01:27 anonymous Note Added: 0004046
2004-04-24 05:53 Curthalion Note Added: 0004056
2004-04-24 12:55 user72 Status feedback => resolved
2004-04-24 12:55 user72 Resolution open => no change required
2004-04-24 12:55 user72 Assigned To => user72
2004-04-24 12:55 user72 Note Added: 0004059


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker