Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001687 [JEDI VCL] 00 JVCL Components tweak always 2004-04-23 14:02 2004-04-25 23:27
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001687: Windows 2000: Keyboard navigation indicators handled wrongly
Description The keyboard navigation indicators (i.e. the focus rectangle of e.g. ButtonControls) are handled wrongly when using JVCL components like TJvButton and Windows 2000. (They are always displayed instead of only displaying them after the Alt key is pressed.)

This is also a VCL bug, but using the TUIStateForm instead of TForm from http://cvs.jrsoftware.org/view/*checkout*/issrc/Projects/UIStateForm.pas?rev=1.1 [^] resolves the problem with the usual TButton. Is it possible to provide such a fix for JEDI VCL too?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004051)
anonymous (viewer)
2004-04-24 04:31

It does occur on Windows XP too if you don't use a manifest file.
(0004052)
AHUser (developer)
2004-04-24 05:03

I do not see this as a bug. I see it as a not supported feature.
(0004055)
user72
2004-04-24 05:06

>I see it as a not supported feature.
Agree, but still might be worth investigating...
(0004061)
user72
2004-04-24 23:45

Andreas, maybe the implementation could be added to TJvExForm? It's only two message handlers, after all (CM_SHOWINGCHANGED and CM_DIALOGKEY). Since you are the head of the JvEx units, I would prefer you doing it.
(0004065)
AHUser (developer)
2004-04-25 07:45

I have added this to TJvExCustomForm and TJvExForm. (not tested)
(0004067)
anonymous (viewer)
2004-04-25 09:02

Yes, the usual VCL components' focus under Win2k behave like under Win98. But the UIStateForm does not fix the JVCL's ones (as well as the BitBtn)... maybe something owner-drawn is the problem.
(0004071)
user72
2004-04-25 23:27

>maybe something owner-drawn is the problem.
Probably, and there is nothing we can do about that (except fix the owner-draw stuff in our derived components when and if they are found).

Please post new bug issues about missing keyboard handling when you find them.

- Issue History
Date Modified Username Field Change
2004-04-23 14:02 anonymous New Issue
2004-04-24 04:31 anonymous Note Added: 0004051
2004-04-24 05:03 AHUser Note Added: 0004052
2004-04-24 05:06 user72 Note Added: 0004055
2004-04-24 23:45 user72 Note Added: 0004061
2004-04-24 23:56 user72 Status new => feedback
2004-04-25 07:45 AHUser Note Added: 0004065
2004-04-25 09:02 anonymous Note Added: 0004067
2004-04-25 23:27 user72 Status feedback => resolved
2004-04-25 23:27 user72 Resolution open => fixed
2004-04-25 23:27 user72 Assigned To => user72
2004-04-25 23:27 user72 Note Added: 0004071


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker