Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001715 [JEDI VCL] 04 Feature Request feature always 2004-05-02 04:36 2006-07-05 04:32
Reporter marcelb View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001715: JvInspector: allow to specify different fonts in the painters
Description Currently the painters do not allow to specify other fonts (all items will use the font specified by the inspector; only different colors can be specified). Should be allowed to specify other fonts or at least another font style.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
child of 0001714closed JvInspector: allow visual feedback of changed items 

-  Notes
(0004145)
Markus Spoettl (reporter)
2004-05-02 06:46

As far as I can tell, I can use other fonts already (through and event in the painter) but the item editor doesn't use that font/color property if it was changed.
(0004147)
marcelb (manager)
2004-05-02 07:10

I realize that, but it would be much better to be able to specify it at design time specifically with regard to 0001714. That would automatically resolve the problem with the editor not using the settings provided by the event, since you would no longer need an event.
(0009769)
obones (administrator)
2006-07-05 04:31

This has now been introduced in SVN.
Every time a Color property was used to control the Font.Color, an associated Font property has been introduced and the Color property removed.
Steps have been taken to allow transparent reading of existing DFM's with non default values for those Color properties.

- Issue History
Date Modified Username Field Change
2004-05-02 04:36 marcelb New Issue
2004-05-02 04:44 marcelb Assigned To => marcelb
2004-05-02 04:44 marcelb Status new => acknowledged
2004-05-02 06:46 Markus Spoettl Note Added: 0004145
2004-05-02 07:10 marcelb Note Added: 0004147
2006-07-04 10:14 marcelb Assigned To marcelb =>
2006-07-05 03:17 obones Relationship added child of 0001714
2006-07-05 04:31 obones Status acknowledged => resolved
2006-07-05 04:31 obones Fixed in Version => Daily / SVN
2006-07-05 04:31 obones Resolution open => fixed
2006-07-05 04:31 obones Assigned To => obones
2006-07-05 04:31 obones Note Added: 0009769


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker