Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001716 [JEDI VCL] 04 Feature Request feature always 2004-05-02 04:39 2006-07-05 03:16
Reporter marcelb View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001716: JvInspector: transform external painter components into internal painter classes.
Description Currently you have to manually place a painter component on the form and link it to the inspector. Since this is commonly forgotten, resulting in an empty inspector, it would be better to make it internal style objects, where the user can select such a style. The style could then default to one of the predefined painter styles and other style can still easily be added later.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004199)
obones (administrator)
2004-05-09 16:32

Keep the components though, because you wouldn't be able to set the events of an internal painter.
Have a look at the JvMenus code to see how we did it.
(0004202)
marcelb (manager)
2004-05-10 01:06

But I want to move those events to the inspector control anyway (all painters have the same events, so they can be moved into the control). I think that using additional components to change the way the main component is rendered or acts is a pain in the behind for many users, and I see no reason to keep the components if (AFAIK) no-one actually uses any custom painter.
(0009768)
obones (administrator)
2006-07-05 03:16

Style property has been introduced, leaving the possibility to use external painters like what is done in JvMenus

- Issue History
Date Modified Username Field Change
2004-05-02 04:39 marcelb New Issue
2004-05-02 04:45 marcelb Assigned To => marcelb
2004-05-02 04:45 marcelb Status new => acknowledged
2004-05-09 16:32 obones Note Added: 0004199
2004-05-10 01:06 marcelb Note Added: 0004202
2006-07-04 10:17 marcelb Assigned To marcelb =>
2006-07-05 03:16 obones Status acknowledged => resolved
2006-07-05 03:16 obones Fixed in Version => Daily / SVN
2006-07-05 03:16 obones Resolution open => fixed
2006-07-05 03:16 obones Assigned To => obones
2006-07-05 03:16 obones Note Added: 0009768


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker