Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001722 [JEDI VCL] 00 JVCL Components major always 2004-05-04 06:26 2004-05-04 09:51
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution won't fix  
Status resolved   Product Version
Summary 0001722: Error "not a valid floating point value" in TJvDBCalcEdit when DecimalSeparator <> '.' like in germany
Description In Germany the ThousandSeparator is '.' and the DecimalSeparator is ','. TJvDBCalcEdit.DataChanged (JvDBControls.pas) produce the errormessage "<value> is not a valid floating point value", because EditText is not converted before passing it to StrToFloat().
The Bug exists also in JVCL Version 2.1, but there DecimalPlaceRound is not comment out and StrToFloat() is never called (it is comment out since Version 1.9 of JvDBControls.pas).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004155)
user72
2004-05-04 09:51

We no longer support JVCL 2.10. Please upgrade to JVCL 3 (a beta release is available from our website) and test if the bug is still present.

If it is, post again.

- Issue History
Date Modified Username Field Change
2004-05-04 06:26 anonymous New Issue
2004-05-04 09:51 user72 Status new => resolved
2004-05-04 09:51 user72 Resolution open => won't fix
2004-05-04 09:51 user72 Assigned To => user72
2004-05-04 09:51 user72 Note Added: 0004155


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker