Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001869 [JEDI VCL] 00 JVCL Components feature always 2004-06-16 14:39 2006-06-10 11:51
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001869: AutoSize, BevelXXXX and ButtonFlat in edits (simple and db aware)
Description Many of JVCL edit control hasnt AutoSize and BevelXXX (BevelEdges, BevelInner, BevelKind and BevelOuter) properties.

I dont remember in which Delphi version began the properties BevelXXXX but isnt all Delphi versions just add conditional compilation.
Additional Information I can do it (as matter of fact I already change some of them in my copy) but I havent write access to CVS.
Tags No tags attached.
Attached Files xls file icon JVCL-Edits.xls [^] (18,432 bytes) 2004-06-18 10:49

- Relationships

-  Notes
(0004576)
user72
2004-06-17 01:26

All controls have AutoSize but not all implement it (ie, nothing happens when you set it to true)

BevelXXX was introduced in the base TWinControl(?) in D6
(0004579)
anonymous (viewer)
2004-06-17 11:29

Hi Peter.
How we can work on this?
(0004582)
user72
2004-06-17 23:45

> How we can work on this?
Well, basically you will have to tell us which controls you think would benefit from having AutoSize published. Publishing AutoSize when it does nothing will just generate reports about AutoSize not working, so it needs to be functional.

BevelXXX is more involved. You could make a list of those controls that could benefit from it as well. We would have to IFDEF them for +D6 only, though.
(0004586)
anonymous (viewer)
2004-06-18 10:53

I just upload the JVCL-Edits.xls file.
I check two pages only (Jv Edits and Jv Data Controls).
Each cell in yellow means that the propertie should be added.
Im not shure if it is possible to use "AutoSize" in TJvExCustomControl's based controls.
As I see, it will be easer to publish the BevelXXXX properties at JV root ancestor than in final controls.

Regards.
(0004592)
user72
2004-06-21 06:19

>As I see, it will be easer to publish the
>BevelXXXX properties at JV root
>ancestor than in final controls.
Maybe easier but certainly not very OO. Someone else will have to figure out how to deal with this since I don't have the time.
(0004595)
anonymous (viewer)
2004-06-21 10:25

I could do it (at "final" classes) but someone must commit the changes to CVS.
Anyone?
(0004900)
obones (administrator)
2004-08-03 07:39

Please provide us with a list of those components, we will look into it.
(0009569)
obones (administrator)
2006-06-10 11:51

Indicated components have been changed in SVN. Should there be other components requiring this, please open a new issue.

- Issue History
Date Modified Username Field Change
2004-06-16 14:39 anonymous New Issue
2004-06-17 01:26 user72 Note Added: 0004576
2004-06-17 11:29 anonymous Note Added: 0004579
2004-06-17 23:45 user72 Note Added: 0004582
2004-06-17 23:46 user72 Status new => feedback
2004-06-18 10:49 anonymous File Added: JVCL-Edits.xls
2004-06-18 10:53 anonymous Note Added: 0004586
2004-06-21 06:19 user72 Note Added: 0004592
2004-06-21 10:26 anonymous Note Added: 0004595
2004-08-03 07:39 obones Note Added: 0004900
2004-10-01 00:04 obones Status feedback => assigned
2004-10-01 00:04 obones Assigned To => obones
2005-02-05 06:47 Cray Issue Monitored: Cray
2006-06-10 11:51 obones Status assigned => resolved
2006-06-10 11:51 obones Resolution open => fixed
2006-06-10 11:51 obones Note Added: 0009569


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker