Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001896 [JEDI VCL] 00 JVCL Components major always 2004-06-25 13:06 2004-12-20 06:19
Reporter sergios View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001896: Problems in TjvMemoryData - working on it
Description In my new project I need some kind of provider/resolver but all controlled by me using TjvMemoryData but found some problems:

1. Blob fields's IsNull allways return true. I already correct this (Bug 0001635).
2. Deleted records are tracked by "Key field". Thats ok at this time. The list dont use ObjectList nor values are objects (are heap allocated variants), when list is cleared the key values arent, this obviusly leads to memory leaks.

// $Id: JvMemoryDataset.pas,v 1.13 2004/06/15 05:33:40 marquardt Exp $
Additional Information Im working on changes to this component.
If someone has objetions or newer version on his machine please tell me.
This is the version Im using:
// $Id: JvMemoryDataset.pas,v 1.13 2004/06/15 05:33:40 marquardt Exp $
Tags No tags attached.
Attached Files

- Relationships
related to 0001635resolvedAHUser BlobField.IsNull not works on TJvMemoryData 
related to 0002257resolved Memory leak in function - DataSetLocateThrough - JvDBUtils.pas 

-  Notes
(0005441)
anonymous (viewer)
2004-10-22 09:16
edited on: 2004-10-22 13:19

In Desc. #2 (mem leak) is fixed with code in ISSUE ID 0002257 IMHO

edited on: 10-22-04 13:19
(0005449)
user72
2004-10-22 13:21

Please update to
// $Id: JvMemoryDataset.pas,v 1.21 2004/09/03 16:16:08 ahuser Exp $
before submitting any code.

Thanks
(0005527)
user72
2004-10-29 02:18

There has been recent updates to this component, so please get the latest version from CVS before uplaoding anything.

Thanks
(0005528)
user72
2004-10-29 02:18

There has been recent updates to this component, so please get the latest version from CVS before uplaoding anything.

Thanks
(0005770)
obones (administrator)
2004-11-30 04:29

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 14 days, we will consider this issue fixed.
(0005950)
obones (administrator)
2004-12-20 06:19

This issue is now considered fixed.
Should it not be the case, please open a new one.

- Issue History
Date Modified Username Field Change
2004-06-25 13:06 sergios New Issue
2004-10-22 09:16 anonymous Note Added: 0005441
2004-10-22 13:19 user72 Note Edited: 0005441
2004-10-22 13:19 user72 Relationship added related to 0001635
2004-10-22 13:19 user72 Relationship added related to 0002257
2004-10-22 13:21 user72 Note Added: 0005449
2004-10-22 13:21 user72 Status new => feedback
2004-10-29 02:18 user72 Note Added: 0005527
2004-10-29 02:18 user72 Note Added: 0005528
2004-11-30 04:29 obones Note Added: 0005770
2004-12-20 06:19 obones Status feedback => resolved
2004-12-20 06:19 obones Resolution open => fixed
2004-12-20 06:19 obones Assigned To => obones
2004-12-20 06:19 obones Note Added: 0005950
2004-12-20 06:19 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker