Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001906 [JEDI VCL] 02 Installation block always 2004-06-30 06:01 2004-11-19 00:53
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0001906: JVCL compilation fails disabling Quick Report (latest CVS)
Description Compilation of latest JVCL tree (using latest JCL tree) fails if Quick Report is disabled.
Additional Information D:\Delphi\Components\JCL-JVCL\JVCL\run\JvgQPrintPreviewForm.pas(190)
Error: Undeclared identifier: 'ExportToExcel'

JvGlobusD7R.dpk(130) Fatal: Could not compile used unit
'..\..\run\JvgQPrintPreviewForm.pas'

The problem is that in JvgExport the conditional defines {$IFDEF JVCL_UseQuickReport} are present, while in JvgQPrintPreviewForm.pas they are not. If Quick Report
is not selected in JVCL.INC should those units be even not considered when the installer builds the packages?
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0004649)
user72
2004-06-30 14:12

Look in <jvcl>\packages\xml\JvGlobus-R.xml. Do you have the following lines
(might wrap):

    <File Name="..\..\run\JvgQPrintPreviewForm.pas"
Targets="d5,d6,d7,c5,c6,k3" Formname="JvgfPrintPreview"
Condition="JVCL_UseQuickReport"/>
    <File Name="..\..\run\JvgQPrintSetupForm.pas"
Targets="d5,d6,d7,c5,c6,k3" Formname="JvgPrintSetup"
Condition="JVCL_UseQuickReport"/>
    <File Name="..\..\run\JvgQRLabel.pas" Targets="d5,d6,d7,c5,c6,k3"
Formname="" Condition="JVCL_UseQuickReport"/>

If not, modify the file and regenerate the packages (with the installer or
pgEdit).

Additionally, I'm not sure how to add multiple conditions to the xml file
(OBones should be able to answer this), but you should have something like
the following in the xml as well (and this applies to JvGlobus-D.xml also):

    <Package Name="qrpt" Targets="D6,D7" Condition="!QREPORT4,
JVCL_UseQuickReport"/>
    <Package Name="qr4rund6" Targets="D6" Condition="QREPORT4,
JVCL_UseQuickReport"/>
    <Package Name="qr4rund7" Targets="D7" Condition="QREPORT4,
JVCL_UseQuickReport"/>

In short, neither JvgQPrintPreviewForm, JvgQPrintSetupForm or JvgQRLabel
should be in uses nor should qrpt, qr4rund6 or qr4rund7 be in requires
unless JVCL_UseQuickReport is defined.
(0005658)
obones (administrator)
2004-11-19 00:53

Because we haven't received any feedback from the original poster for a long time, we consider this issue to be resolved. Should it not be, please first start using the daily zips:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

and if that doesn't work, please post a new issue.

- Issue History
Date Modified Username Field Change
2004-06-30 06:01 anonymous New Issue
2004-06-30 14:12 user72 Note Added: 0004649
2004-07-05 00:31 obones Status new => feedback
2004-11-19 00:53 obones Status feedback => resolved
2004-11-19 00:53 obones Resolution open => fixed
2004-11-19 00:53 obones Assigned To => obones
2004-11-19 00:53 obones Note Added: 0005658


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker