Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002061 [JEDI VCL] 00 JVCL Components minor always 2004-08-16 23:42 2004-11-30 04:24
Reporter roko View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002061: TJvAnimatedImage doesn't work on WinXP
Description TJvAnimatedImage doesn't show on the form in runtime when program is run on Win XP (SP1 if that matters). It's simply empty space in place where image should be. The same program ran on Win2000 without problem. Moreover, at design time image is visible, and when activated, animation is working.

On investigation, I discovered that setting Opaque := True makes image visible at run time, too. So, is it culprit?
Additional Information JVCL 3. Delphi 7.
// $Id: JvAnimatedImage.pas,v 1.26 2004/07/26 16:52:26 marquardt Exp $
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005000)
roko (reporter)
2004-08-16 23:47

Sorry for duplicate - connection glitch.
(0005002)
user72
2004-08-17 00:10

Dupe deleted (#2060)
(0005003)
user72
2004-08-17 00:11
edited on: 2004-08-17 01:17

>On investigation, I discovered that setting Opaque := True makes
> image visible at run time, too. So, is it culprit?
Maybe. Are you using a manifest on XP?

edited on: 08-17-04 01:17
(0005004)
roko (reporter)
2004-08-17 00:59

I tried using a manifest, it doesn't change anything.
(0005008)
roko (reporter)
2004-08-17 07:57

I forgot to add that animated images I speaking about were working OK on both W2K and XP when I used JVCL 2.10. This changed only when I switched to JVCL3 (2004-08-05). This is even more curious because code used to draw TJvAnimatedImage is virtually unchanged since 2.10 (some conditional code removed) (I mean CopyParentImage from JvJVCLUtils.pas as well as TJvAnimatedImage.DoPaintImage).

Just an aside:
I noticed that only TJvAnimatedImage class has property 'Opaque'. Every other component in JVCL has property 'Transparent', if applicable.
(0005009)
user72
2004-08-17 13:09

> I noticed that only TJvAnimatedImage class has property 'Opaque'.
> Every other component in JVCL has property 'Transparent', if applicable.
That should probably be changed or at least Opaque made public (and marked as deprecated) and a new published Transparent property added
(0005016)
user72
2004-08-18 00:40

Opaque renamed to Transparent in CVS. Previously stored Opaque values in DFM files should be read into Transparent instead.
(0005671)
obones (administrator)
2004-11-19 01:29

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005768)
obones (administrator)
2004-11-30 04:24

It has been 11 days, this issue is now considered as resolved. Please post a new one should you think this is not the case.

- Issue History
Date Modified Username Field Change
2004-08-16 23:42 roko New Issue
2004-08-16 23:47 roko Note Added: 0005000
2004-08-17 00:10 user72 Note Added: 0005002
2004-08-17 00:11 user72 Note Added: 0005003
2004-08-17 00:59 roko Note Added: 0005004
2004-08-17 01:17 user72 Note Edited: 0005003
2004-08-17 07:57 roko Note Added: 0005008
2004-08-17 13:09 user72 Note Added: 0005009
2004-08-18 00:40 user72 Note Added: 0005016
2004-11-19 01:29 obones Note Added: 0005671
2004-11-19 01:29 obones Status new => feedback
2004-11-30 04:24 obones Status feedback => resolved
2004-11-30 04:24 obones Resolution open => fixed
2004-11-30 04:24 obones Assigned To => obones
2004-11-30 04:24 obones Note Added: 0005768
2004-11-30 04:24 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker