Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002124 [JEDI VCL] 00 JVCL Components tweak always 2004-09-06 04:57 2004-10-25 02:51
Reporter miracle2k View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002124: JvgStaticText flickering
Description If you move the mouse above a JvgStaticText component, and if the ActiveColor property is the same as the Canvas.Font.Color property (clWindowText),you can see a little flickering, really small, but it's there if you look closely (at least on my Windows XP machine).

However, many people might not need the Hover feature. Personally, I use JvgStaticText because it can display texts justified. So I suggest introducing a new boolean property like "Hover", which can be used to turn this behaviour on/off.

In MouseLeave() and MouseEnter() procedure the following line would be necessary:

if not (ActiveColor = Font.Color) then Repaint;
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005478)
user72
2004-10-25 02:51

No Hover property added but you can set ACtiveColor to clNone to have the same effect:

Your proposed change for MouseEnter/MouseLeave was modified to:

   if not (ActiveColor = Font.Color) and (ActiveColor <> clNone) then
    Repaint;

Updated in CVS. Thanks!

- Issue History
Date Modified Username Field Change
2004-09-06 04:57 miracle2k New Issue
2004-09-06 04:59 miracle2k Issue Monitored: miracle2k
2004-10-25 02:51 user72 Status new => resolved
2004-10-25 02:51 user72 Resolution open => fixed
2004-10-25 02:51 user72 Assigned To => user72
2004-10-25 02:51 user72 Note Added: 0005478


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker