Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002126 [JEDI VCL] 00 JVCL Components minor always 2004-09-06 05:06 2004-11-30 03:57
Reporter Kaj Ekman View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002126: TJvCalcEdit Button-width not saved
Description Unable to hide button beacuse width always resetted to 21
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005220)
RayA (developer)
2004-09-12 00:43

There appears to be a wierd problem going on when setting the button width to zero. When the form is reloaded in the Delphi IDE it remembers the value prior to having set the button with to zero.
(0005221)
RayA (developer)
2004-09-12 00:57

Recommend using the ShowButton property instead.

By having republished the ShowButton property, from the TJvCustomComboEdit ancestor class, the problem appears to be solved however a minor quirk remains. When setting the ButtonWidth to 0 the ShowButton will automatically be set to False and the ButtonWidth property is reset again back to it's old property. Not a big deal since the ShowButton property takes precedence.
(0005664)
obones (administrator)
2004-11-19 01:03

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005764)
obones (administrator)
2004-11-30 03:57

No news for the past 11 days, we consider this issue to be fixed. Should this not be the case, please open a new issue.

- Issue History
Date Modified Username Field Change
2004-09-06 05:06 Kaj Ekman New Issue
2004-09-12 00:43 RayA Note Added: 0005220
2004-09-12 00:43 RayA Status new => confirmed
2004-09-12 00:57 RayA Note Added: 0005221
2004-09-12 00:57 RayA Status confirmed => feedback
2004-11-19 01:03 obones Note Added: 0005664
2004-11-30 03:57 obones Status feedback => resolved
2004-11-30 03:57 obones Resolution open => fixed
2004-11-30 03:57 obones Assigned To => obones
2004-11-30 03:57 obones Note Added: 0005764
2004-11-30 03:57 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker