Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002153 [JEDI VCL] 00 JVCL Components major always 2004-09-17 11:47 2006-06-08 03:37
Reporter Daniel Simon View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002153: ENTER Key not working with JvDBLookupCombo
Description when the component receive the focus and we type a value found at the drop down list, after the ENTER key is pressed
the list is closed but the selected value is lost. But if you use the sequence: ALT + UP ARROW KEY, the selected value is correctly captured.
Additional Information After tracing the code I think the problem could be on the
procedure TJvDBLookupCombo.KeyDown: the CloseUp() is not executed when the ENTER key is pressed.
On time: I assigned these properties: LookUpDisplay/LookUpField and LookUpSource.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008732)
obones (administrator)
2006-03-30 02:29

I cannot reproduce this with the latest version (3.20 - CVS). Could you post a sample application if you can still reproduce it?
(0008875)
DSimon (reporter)
2006-04-04 05:40

After testing this issue with a new version (change log dated 2006-01-11) the problem seems to be solved.
(0009445)
obones (administrator)
2006-06-08 03:37

Thanks for letting us know.

- Issue History
Date Modified Username Field Change
2004-09-17 11:47 Daniel Simon New Issue
2006-03-30 02:29 obones Note Added: 0008732
2006-03-30 02:29 obones Status new => feedback
2006-04-04 05:40 DSimon Note Added: 0008875
2006-06-08 03:37 obones Status feedback => resolved
2006-06-08 03:37 obones Resolution open => fixed
2006-06-08 03:37 obones Assigned To => obones
2006-06-08 03:37 obones Note Added: 0009445


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker