Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002164 [JEDI VCL] 00 JVCL Components minor always 2004-09-22 00:27 2004-10-05 11:46
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002164: CopyToClipboard on RichEdit doesn't work
Description Put a JvRichEdit on a form, put some text in, use the CopyToClipboard function and try to past the text, it won't work. If you try the same on the standard combobox it does work.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0002142resolvedobones FClipboardCommands not set in JvExMask.pas 
related to 0002177resolvedremkobonte TJvComboEdit - does not process clipboard commands 

-  Notes
(0005243)
anonymous (viewer)
2004-09-22 00:29

Excuse me, that should be memobox, not combobox.
(0005244)
remkobonte (developer)
2004-09-22 11:42

This is because FClipboardCommands is not set to its default value in the constructor of TJvExCustomMemo.
(0005245)
anonymous (viewer)
2004-09-22 11:55

Also the methods ClearSelection, CutToClipboard, PasteFromClipboard, Undo and Redo do not work with 3.00 BETA 2

(Tested with Delphi 7.1 Prof. on WinXP SP2)
(0005249)
user72
2004-09-23 04:46

I was going to suggest a temporary fix: set ClipboardCommands in code in the forms constructor, i.e:

procedure TForm1.FormCreate()
begin
  JvRichEdit1.ClipboardCommands := [caCopy, caCut, caPaste, caUndo]
end;

But I now see that ClipboardCommands is not published in JvRichEdit, so maybe that is a new bug report?
(0005276)
obones (administrator)
2004-09-30 23:09

Fred has provided a fix for this bug, it is in CVS. Please try it and let us know it goes.
(0005284)
remkobonte (developer)
2004-10-03 15:14

Works for me :)

ClipboardCommands should be published IMO.
(0005289)
user72
2004-10-04 05:24

> ClipboardCommands should be published IMO.
I am thinking protected in JvCustomXXX but definitely published in JvRichEdit, JvMemo, JvEdit etc.
(0005295)
remkobonte (developer)
2004-10-04 11:43

Yeah, that is what I meant <g>
(0005321)
user72
2004-10-05 11:46

published ClipboardCommands + set default value in constructor

- Issue History
Date Modified Username Field Change
2004-09-22 00:27 anonymous New Issue
2004-09-22 00:29 anonymous Note Added: 0005243
2004-09-22 11:40 remkobonte Relationship added related to 0002142
2004-09-22 11:42 remkobonte Note Added: 0005244
2004-09-22 11:55 anonymous Note Added: 0005245
2004-09-22 15:36 Cray Issue Monitored: Cray
2004-09-23 04:46 user72 Note Added: 0005249
2004-09-25 00:58 user72 Status new => feedback
2004-09-25 02:04 user72 Issue Monitored: user72
2004-09-27 10:19 user72 Relationship added related to 0002177
2004-09-30 23:09 obones Note Added: 0005276
2004-10-01 05:29 obones Issue Monitored: obones
2004-10-03 15:14 remkobonte Note Added: 0005284
2004-10-04 05:24 user72 Note Added: 0005289
2004-10-04 11:43 remkobonte Note Added: 0005295
2004-10-05 11:46 user72 Status feedback => resolved
2004-10-05 11:46 user72 Resolution open => fixed
2004-10-05 11:46 user72 Assigned To => user72
2004-10-05 11:46 user72 Note Added: 0005321
2005-02-05 06:45 Cray Issue End Monitor: Cray
2005-08-28 09:33 obones Issue End Monitor: obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker