Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002166 [JEDI VCL] 00 JVCL Components minor always 2004-09-23 06:26 2005-02-15 17:46
Reporter pierre.muller View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002166: TJvAppIniFileStorage and float properties
Description When saving "Value" property of a TJvSpinEdit, it is not restored. A workaround is:
StorageOptions.FloatAsString:= true;
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005643)
jfudickar (developer)
2004-11-16 15:31

Erinnerung gesendet an asnepvangers

Hi,

please have a look at this bug.

I have removed the changes in read/write-float because of the bugs.

Greetings
Jens
(0005645)
asnepvangers (developer)
2004-11-17 14:39
edited on: 2004-11-19 11:28

Hi,

 
DoRead/WriteFloat are using BinStrToBuf / BufToBinStr now, avoiding DoRead/WriteBinary(!).
Changed Default FloatAsString to False.
Changed JvXMLStorage DoRead/WriteFloat in same manner.
BinStrToBuf/BufToBinStr are implemented in JvJCLUtils.

Regards,
André

edited on: 11-19-04 11:28
(0005646)
asnepvangers (developer)
2004-11-17 16:11

Fixed in latest CVS

- Issue History
Date Modified Username Field Change
2004-09-23 06:26 pierre.muller New Issue
2004-11-16 15:31 jfudickar Issue Monitored: asnepvangers
2004-11-16 15:31 jfudickar Note Added: 0005643
2004-11-17 14:39 asnepvangers Note Added: 0005645
2004-11-17 16:10 asnepvangers Resolution open => fixed
2004-11-17 16:11 asnepvangers Note Added: 0005646
2004-11-18 00:58 jfudickar Status new => assigned
2004-11-18 00:58 jfudickar Assigned To => asnepvangers
2004-11-19 11:28 asnepvangers Note Edited: 0005645
2005-02-15 17:37 jfudickar Status assigned => resolved
2005-02-15 17:46 jfudickar Assigned To asnepvangers =>
2005-02-15 17:46 jfudickar Status resolved => feedback
2005-02-15 17:46 jfudickar Resolution fixed => reopened
2005-02-15 17:46 jfudickar Status feedback => resolved
2005-02-15 17:46 jfudickar Fixed in Version => 3.00 BETA 2
2005-02-15 17:46 jfudickar Resolution reopened => fixed
2005-02-15 17:46 jfudickar Assigned To => jfudickar


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker