Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002187 [JEDI VCL] 99 Other tweak N/A 2004-09-30 09:02 2004-10-14 13:09
Reporter Nanotonne View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002187: minor update french translation JVCLInstall.po and correction minor for installation program
Description - i have corrected the .po french because i have see a update JVCL and all is not translated.
- how to translate a file? because jvclinstall program open a files and we can't translate for integration for compiling. it's a problem ! see button "edit jvcl.inc", the label (lblcomment) caption at rigth position for helping information from left list of checkbox come from a file (description dynamic)! possible to implement a method with using dxgettext to open the associate translating file? for example :
filename='myfile1.text';
memo1.loadfromfile(filename);
and dxgettext change dynamically the fimename value by 'fr-myfile1.text' if a have "translated" 'myfile1.text' by 'fr-myfile1.text' in .po file, not a good idea? other suggestion or idea ???
- thank too to correct the value in install/JVCLInstall/Frames/FrmPackageSelection.dfm button btnreset :
left = 360
width = 145
(previous is left = 384 and width = 129)
because in french the button is too short to view name button !
- the hotlink label (LblDxgettextHomepage) is present but visible=false, why ?
thank to update the .po french
Additional Information
Tags No tags attached.
Attached Files ? file icon JVCLInstall.po [^] (37,328 bytes) 2004-09-30 09:02

- Relationships

-  Notes
(0005344)
Nanotonne (reporter)
2004-10-07 14:33

Why the button RESET package is now no visible ?
can i have a response/explain for my previous questions please (top this bug tracking), have you lose me ? thank !
(0005385)
obones (administrator)
2004-10-14 13:09

1. Thanks, this is now in CVS
2. The only place where the translations are is in the Po file. They get compiled to MO file when the installer is run through install.bat. If you want to edit the Po file, close the installer, use PoEdit from http://poedit.sf.net/ [^] save your changes then restart the installer.
3. This is now updated in CVS.
4. No idea, I guess it is lacking space. I've posted a question on the newsgroup, please follow up there.

- Issue History
Date Modified Username Field Change
2004-09-30 09:02 Nanotonne New Issue
2004-09-30 09:02 Nanotonne File Added: JVCLInstall.po
2004-09-30 23:10 obones Status new => assigned
2004-09-30 23:10 obones Assigned To => obones
2004-10-07 14:33 Nanotonne Note Added: 0005344
2004-10-14 13:09 obones Status assigned => resolved
2004-10-14 13:09 obones Resolution open => fixed
2004-10-14 13:09 obones Note Added: 0005385


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker