Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002204 [JEDI VCL] 04 Feature Request minor always 2004-10-11 06:08 2005-05-20 03:05
Reporter Nanotonne View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002204: need extended components based on TJVedit but with a tJvlabel
Description often, I need to associate a "label" with a "edit" component because no "title/description" for most components are not present but requiert (combobox, listbox, edit, checkbox, filebox, directorybox, etc ....), see examples in jpg attached file.
If i paste a JvFilenameEdit, i need too to paste a label description (example : "select a texte file source :") at top or left position (or other), and if i move the first component, i need to move too the label (or other label derived type) :-(

I have very very searched this features/components in jvcl but i don't have found ! :-(
 
Why not create a derived components to/with associate component with a label (or static text, ...), it's best and easy for user, no?
For example : TJVFileNameExtended = JVFileNameExtended+TJVHTLabel; ...
or add a bases properties for most components(editing, combo, checkbox) called :labelized=boolean;alignement=(left,top,botom,right);labelmargin=integer(pixel);JVHTLabel:TJVHTLabel.

The very priority is for JvFilenameEdit, JvDirectoryEdit, JvxxxxxEdit and after JvxxxxxBox (and after, ????)

Thank to help/response me ! (create/modify components)
Additional Information
Tags No tags attached.
Attached Files jpg file icon exampleassociationlabel.jpg [^] (24,425 bytes) 2004-10-11 06:08
zip file icon JvAssociatedControl.zip [^] (2,744 bytes) 2004-10-13 01:59

- Relationships

-  Notes
(0005354)
user72
2004-10-11 10:35

JVCL already contains a lot of components (too many some think), so adding additional specialized components isn't a good idea. Additionally, as soon as we decide to use TJvLabel, someone will say "I would like to use JvHTLabel instead". If we decide to do it with JvHTLabel, someone will say "I don't want to use JvHTLabel or JvLabel, I want standard TLabel instead".

Frames are simple, you can design them as you like and reuse as much as you want, so that is what I recommend in this case.
(0005355)
Nanotonne (reporter)
2004-10-11 15:23

OK, i understand what you say. (i don't lnow good frames, it's for that!)
But... in certain case....it's need/requiert no? often for JVFileNameEdit and JVDirectoryEdit a "label" title is necessary added (each time). but.....i unnderstand !
It's not possible to define in jvcl a set of default frames often used for user, possible it's good idea?
or add a property to link 2 or more visual components for (all) components ? (example "published AssociatedControl:=tcontrol" and possibly "fixedControl:=boolean"), then we can associate any component with any other !? It's more simpler than frames no ? and compatible too with all actually components !
What do you think ?
(0005356)
user72
2004-10-12 04:19

>What do you think ?
Supplying a set of default frames is a good idea. In fact, I once thought about converting some of the JVCL dialog components to frames (DualListDlg etc) but never got around to it. Adding an "AssoicatedControl" property is also a pretty good idea.

As everything else, it is a matter of available time :)
(0005370)
Nanotonne (reporter)
2004-10-12 15:35

okay, can you provide for testing only one (or two) component with this feature ?
we Select for example JVFileNameEdit ( and JVDirectoryEdit) for test :
-> with "AssociatedControltemporaryfortestingonly" tcomponent property if you put unit in cvs for public and for everybody test and send comment here (and why not help), OR,
-> a modified file unit with "AssociatedControl" tcomponent property and you post here for me the modified file unit for i test and help-you/try to (me I) write code for other components, because i'm not very good in programming object and creating component,i'm good only for "traditionnal programming feature" with function, procedure, ...but for "destructor, constructor, object", .. hum, hum!....
-> or help me to code this feature (because see previously!) and i code and post here if it work.

ps : can you get me your email please, if possible ? i don't have found your profile in mantis for find you email, thank.

i think if this feature is implemented (or a derived) it will be very success for the user! :-)

nanotonne (with no "s" for nanotonne at the end, not nanotoone too, or .... ;-) pether3 ouups peter3 ! )
(0005375)
user72
2004-10-13 02:06

I don't have time to do it myself, but I've uploaded a demo with an implementation that should get you started. The demo uses a helper class (so you won't have to implement the same code over and over again). The control (in this case a TEdit), creates an instance of the helper class, and calls its UpdateAssociate procedure at appropriate times (when a control is removed and when its own bounds are changed).

I haven't tested it at design-time, but it works fine at run-time AFAICS
(0005378)
Nanotonne (reporter)
2004-10-13 16:37

ok, i will go to read/test your file this week (end). thank !
(0007263)
obones (administrator)
2005-05-20 03:05

I'm considered this to be resolved, it's been over 6 months, the week-end is very long ;-)

- Issue History
Date Modified Username Field Change
2004-10-11 06:08 Nanotonne New Issue
2004-10-11 06:08 Nanotonne File Added: exampleassociationlabel.jpg
2004-10-11 10:35 user72 Note Added: 0005354
2004-10-11 15:23 Nanotonne Note Added: 0005355
2004-10-12 04:19 user72 Note Added: 0005356
2004-10-12 15:35 Nanotonne Note Added: 0005370
2004-10-13 01:59 user72 File Added: JvAssociatedControl.zip
2004-10-13 02:06 user72 Note Added: 0005375
2004-10-13 02:06 user72 Issue Monitored: user72
2004-10-13 16:37 Nanotonne Note Added: 0005378
2004-10-22 14:00 user72 Status new => acknowledged
2005-05-20 03:05 obones Status acknowledged => resolved
2005-05-20 03:05 obones Resolution open => fixed
2005-05-20 03:05 obones Assigned To => obones
2005-05-20 03:05 obones Note Added: 0007263


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker