Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002231 [JEDI VCL] 00 JVCL Components major always 2004-10-16 13:20 2004-10-22 13:42
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002231: TJvValidateEdit doesn't accept Value(s) greater than 255
Description Hi,

TJvValidateEdit does not accept Values greater than 255, when DisplayFormat is set to dfHex and the Value is set through code.

It replaces the Value with a zero instead.

To reproduce the error, put a TJvValidateEdit and a TButton on the Form and then use this code:


procedure TForm1.Button1Click(Sender: TObject);
begin
  JvValidateEdit1.DisplayFormat := dfHex;
  JvValidateEdit1.Value := 2048; // Does not work!
  //JvValidateEdit1.Value := 255; // Works!
end;
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0002328resolved TJvValidateEdit doesn't accept Value(s) greater than 255 

-  Notes
(0005406)
anonymous (viewer)
2004-10-16 13:29

In JvValidateEdit.pas line 891:

function TJvCustomValidateEdit.IntToBase(NewValue, Base: Byte): string;

The parameter NewValue must be an Integer, or better an Int64.
(0005407)
anonymous (viewer)
2004-10-16 13:39

procedure TJvCustomValidateEdit.SetAsInteger(NewValue: Integer);

should be also use an Int64
(0005408)
anonymous (viewer)
2004-10-16 13:39

function GetAsInteger: Integer;

Should be also use an Int64
(0005410)
anonymous (viewer)
2004-10-16 13:40

function BaseToInt(const BaseValue: string; Base: Byte): Integer;

also an Int64

Basically every Integer an Int64 :)
(0005455)
user72
2004-10-22 13:42

Fixed in CVS. Note that I chose Integer, not Int64, since D5 doesn't support implicit conversion between Int64 and Variant

- Issue History
Date Modified Username Field Change
2004-10-16 13:20 anonymous New Issue
2004-10-16 13:29 anonymous Note Added: 0005406
2004-10-16 13:39 anonymous Note Added: 0005407
2004-10-16 13:39 anonymous Note Added: 0005408
2004-10-16 13:40 anonymous Note Added: 0005410
2004-10-22 13:42 user72 Status new => resolved
2004-10-22 13:42 user72 Resolution open => fixed
2004-10-22 13:42 user72 Assigned To => user72
2004-10-22 13:42 user72 Note Added: 0005455
2004-11-23 23:32 user72 Relationship added has duplicate 0002328


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker