Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002266 [JEDI VCL] 02 Installation major always 2004-10-25 19:32 2004-10-29 02:13
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002266: cannot install jvcl, error when compile packages
Description allways when i want install de lasted version of jvcl that errors happned.

i think that have some " " in the path line.
The screenshot is attached
Additional Information [Compiling: Packages]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Compiling: Jv3rdD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
4246 lines, 0.23 seconds, 27000 bytes code, 117 bytes data.

Fatal: '"C:\Arquivos de programas\Borland\Delphi7\Projects\Bpl"\DJclVcl.dcp' does not exist - don't know how to make it

** error 1 ** deleting CompilePackages
Tags No tags attached.
Attached Files jpg file icon error.JPG [^] (42,448 bytes) 2004-10-25 19:32
jpg file icon ERROR2.JPG [^] (61,582 bytes) 2004-10-27 03:06

- Relationships
has duplicate 0002277resolveduser72 Unable to install 

-  Notes
(0005503)
Nanotonne (reporter)
2004-10-26 05:42

have you too downloaded the last JCL ??
i have already this probleme 4 month before because i have the last JVCL but not last JCL !

* remember download 2 links : *
- download last JVCL at : http://jvcl.sourceforge.net/daily/JVCL3-Latest.zip [^]
- download last JCL at : http://jcl.sourceforge.net/daily/jcl-Latest.zip [^]

with this 2 zips you have alwas latest version. uninstall jvcl and jcl, and re-install jcl and after jvcl, and after if you have a probleme, send here new note !
(0005510)
anonymous (viewer)
2004-10-27 03:13

Hello,

I´m have unistalled delphi im my machine, after installing d7 again, I´m donwloaded de lasted version of jvcl and jcl (at these link was you sad), jcl is install with no problens, but, on installing jvcl, have a error ocurred because i don´t have installed de QuickReports components (and after installing QuickReport) the error 2 was happend ( the file is attached )

what is the correct version of quickreport needed ?
or is there other error ?
(0005511)
Nanotonne (reporter)
2004-10-27 08:29

okay, i read in jvgqprintpreviewform :

procedure TJvgfPrintPreview.tbExportExcelClick(Sender: TObject);
begin
  ExportToExcel(QR);
end;

the ExportToExcel procedure is declared/write in the JvgExport.pas unit (line 65):
{$IFDEF JVCL_UseQuickReport}
procedure ExportToExcel(QuickRep: TCustomQuickRep);
(....)

have you JvgExport.pas unit ? i assume yes ! (in .\jvcl\run\ directory)
it mean you don't install jvcl correctly, probably.
Check :
totally uninstalled jvcl, and jcl : jvcl = install.bat/uninstall, and try after clean.bat, delete all directory jvcl and too the jv*.* file in all directoriies delphi : you need to good clean ALL files and reference at jvcl before install it, because probleme possible (i think) conflict, warning to don't delete windows or delphi files !! check good it !!!!!
after, uninstall jcl with clean.bat from jcl directory, clean all and check (exactlly as jvcl previously describle)
At the end checking you should SURE to GOOD uninstalled jcl and jvcl from directories, references file and files jcl/jvcl in delphi directories!....
Now nothing should be present : you are sure? ok, after :

redownload the latest 2 zip, because it come to temporary bug (rarely), but 1 or 2 day after, all work (compilling and install) correctly, (i suggest to reboot after your computer if paranoiac ...)

uncompress latest zip jvcl ALL in C:\Arquivos de programas\Borland\JCLJVCL\JVCL\ (JVCLJCL is my config it work for me ...)
now you have C:\Arquivos de programas\Borland\JCLJVCL\JVCL\install.bat, todo.txt, jvcl3.txt, etc....

uncompress latest zip jcl ALL in C:\Arquivos de programas\Borland\JCLJVCL\JCL\
now you have C:\Arquivos de programas\Borland\JCLJVCL\JCL\install.bat, dist-excludes, want.exe, Install.txt, etc....
ok? (i explain what is my preferences/my install for me only peronally i do ! :-)

RUN C:\Arquivos de programas\Borland\JCLJVCL\JCL\install.bat and click "install"
After finished
RUN C:\Arquivos de programas\Borland\JCLJVCL\JVCL\install.bat and click (new install) next, next, set checked : build packages, clean palette components jvcl, develloper install jvcl, register global editor, dxgettextsupport, jvgif record for .gif files, use JVCL for all packages, unit versioning, output detailled, click NEXT, NEXT, INSTALL
Normally all should work compiling/installing.

if you have error.... i don't none! :-( : End to help you for me, waiting more days to re-donwload new version jcl and jvcl to retry !?!.....
is important to check a good cleaning uninstalling jcljvcl for you fo BEST lucky good to installing successfull! repost here you result !
(0005512)
Nanotonne (reporter)
2004-10-27 08:40

all packages sould be installed, no reason to error for quickreport !
the correct version is in your zip normally (the last!) !
(0005514)
anonymous (viewer)
2004-10-28 09:13

Hello,

The problem was that another application have installed an .bpl in \windows\system32, and, i don't have a quickreport installed, after correct this i installed the jvcl.

Thank's
(0005515)
Nanotonne (reporter)
2004-10-28 09:51

okay! this bug can be close/resolved !

if peter3 or other can do that (no permission to change state bug in "resolved")
thank!
(0005525)
user72
2004-10-29 02:13

Too bad I can't set this as "resolved by Nanotonne" :)

- Issue History
Date Modified Username Field Change
2004-10-25 19:32 anonymous New Issue
2004-10-25 19:32 anonymous File Added: error.JPG
2004-10-26 05:42 Nanotonne Note Added: 0005503
2004-10-27 03:06 anonymous File Added: ERROR2.JPG
2004-10-27 03:13 anonymous Note Added: 0005510
2004-10-27 08:29 Nanotonne Note Added: 0005511
2004-10-27 08:40 Nanotonne Note Added: 0005512
2004-10-28 09:13 anonymous Note Added: 0005514
2004-10-28 09:51 Nanotonne Note Added: 0005515
2004-10-29 02:13 user72 Status new => resolved
2004-10-29 02:13 user72 Resolution open => fixed
2004-10-29 02:13 user72 Assigned To => user72
2004-10-29 02:13 user72 Note Added: 0005525
2004-10-31 03:15 user72 Relationship added has duplicate 0002277
2004-11-25 06:05 willo Issue Monitored: willo
2004-11-25 06:05 willo Issue End Monitor: willo


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker