Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002275 [JEDI VCL] 00 JVCL Components major always 2004-10-30 09:07 2004-11-24 08:24
Reporter bugfinder View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002275: Appstorage odd result
Description Appstorage not always reading/writeing ini files as expected.
Additional Information When you I came to you originally you adjusted the appstorage component for me, and it worked a treat. Recently I felt I should download the newer beta versions as other components would have been fixed.

After installation I went back to my test project.

If run from the IDE it seems to make a 0 byte file in the delphi bin directory. Even on removal, and providing a previously working ini file ensuring it was in the correct directory and ensuring there were no dups in path, it still wasnt actually reading/writing the specified component properties.

I have reworked the example and attached it, to show you what i mean, with the previous version I had, it loaded 5 worlds, now it claims 1, which is the default put in one, so in fact its not actually loading any. In fact, rename the ini and save, and it doesnt even save the first one..

I couldnt find any documentation on why this would be such different behaviour. Especially the ini file location.
Tags No tags attached.
Attached Files zip file icon example.zip [^] (9,223 bytes) 2004-10-30 09:07

- Relationships

-  Notes
(0005530)
bugfinder (reporter)
2004-10-30 09:21

Oops, ps comment out the following

{ aworld.SSL := false;
         aworld.character := 'Guest';
         aworld.passwd := 'guest';
         aworld.AutoReconnect := false;
         aworld.AutoConnect := false;
         aworld.autolog := false;
         aworld.disableansi := false;
         aworld.TextFont.name:='FixedSys';
         aworld.TextFont.size:=9;
// aworld.fontname := 'FixedSys';
// aworld.fontsize :=9;
         aworld.UsecolourDefaults := false;
         aworld.Indent := false;
         aworld.keepalive:=true;
         }

Sorry. I forgot to hit save !
(0005553)
anonymous (viewer)
2004-11-02 13:18

Sorry, i can't reproduce your sample.

When i open it, the TWorldStore component is removed, and so nothing is loaded.

I've changed
  object JvFormStorage1: TJvFormStorage
    AppStorage = JvAppIniFileStorage1
    Active = True //changed
    Options = [fpState, fpSize, fpLocation, fpActiveControl] //changed
    StoredValues = <>
    Left = 203
    Top = 3
  end
  object JvAppIniFileStorage1: TJvAppIniFileStorage
    StorageOptions.BooleanStringTrueValues = 'TRUE, YES, Y'
    StorageOptions.BooleanStringFalseValues = 'FALSE, NO, N'
    StorageOptions.SetAsString = True
    AutoFlush = True //changed
    AutoReload = True //changed
    FileName = 'MC.ini'
    DefaultSection = 'General'
    SubStorages = <>
    Left = 272
    Top = 8
  end


And then the formposition is stored and restored.

So please give us a better example
(0005554)
jfudickar (developer)
2004-11-02 13:20

Last Comment : it was me :-)
(0005556)
bugfinder (reporter)
2004-11-02 13:30
edited on: 2004-11-02 13:31

Try adding the MC.pas file in the example to your registered components :P

The problem was originally it would kindly save the contents of the worldstore, now it doesnt. It doesnt, it doesnt say why either, it just kinda doesnt.

edited on: 11-02-04 13:31
(0005584)
jfudickar (developer)
2004-11-07 13:45

Sorry, for me store couldn't have working in any time. TCollection's were not stored automaticly. I have changed this now.

It should work. The only thing is, that the format of the entries is changed. Save the one entry you have, and then you see the new format.

Greetings
Jens
(0005585)
bugfinder (reporter)
2004-11-07 15:53

I will have a look.. At the time I reported http://homepages.borland.com/jedi/issuetracker/view.php?id=1642 [^] though it was working hence compiled with the older version of your code the example worked and the new one it didnt, hence I reported it.
(0005586)
jfudickar (developer)
2004-11-08 00:32

I know the issue you mentioned (because i had worked on it), but i couldn't understand it.
I had looked through the changes, but i can't find it.

Hopefully it works now.

Greetings
Jens
(0005640)
jfudickar (developer)
2004-11-16 08:33

Any News ??
(0005674)
anonymous (viewer)
2004-11-19 02:29
edited on: 2004-11-19 02:29

Sorry, been a bit busy.

Will download now and try, I hate having to play with your CVS though.

edited on: 11-19-04 02:29
(0005675)
anonymous (viewer)
2004-11-19 02:33

Actually, I cant do CVS atm. Can you post the changed files so I can try.
(0005676)
jfudickar (developer)
2004-11-19 03:39

Upload is not so easy, because of a lot of fixes and changes to the components in the last days.

Please use the daily files. They should contain the right version:
http://jvcl.sourceforge.net/daily/JVCL3-Latest.zip [^]

You need also the current jcl release:
http://prdownloads.sourceforge.net/jcl/JCL1.93-Build1722a.zip?download [^]

Greetings
Jens
(0005677)
anonymous (viewer)
2004-11-19 04:22

Thanks for that, didnt know there was a cvs zip file :)

However, currently the installation of that file dies with

C:\Program Files\Borland\Delphi5\Source\jvcl\run\JvListView.pas(113) Error: Method 'CreateListItems' not found in base class
JvStdCtrlsD5R.dpk(114) Fatal: Could not compile used unit '..\..\run\JvListView.pas'

:(

Will try tomorrow.
(0005678)
jfudickar (developer)
2004-11-19 05:15

Yes we have a problem with JvListView.pas and d5.

Please comment the CreateListItems function. This should fix your problem.

This function was introduced in d6 and so we had to find a workaround for this.

Greetings
Jens
(0005681)
bugfinder (reporter)
2004-11-19 06:44

Hmm, ok, that seemed to make a difference.

It didnt read the old ini file, but did read the new one, so something internally changed so it couldnt read it, but hey.. it works now..

I think :) If it doesnt. I'll be back!
(0005682)
jfudickar (developer)
2004-11-19 06:50

We will wait a moment and if we didn't hear anything from you we will close the case :-)
(0005695)
anonymous (viewer)
2004-11-24 07:28

Still looking good.. got a new bug /request though :P will post.

- Issue History
Date Modified Username Field Change
2004-10-30 09:07 bugfinder New Issue
2004-10-30 09:07 bugfinder File Added: example.zip
2004-10-30 09:21 bugfinder Note Added: 0005530
2004-11-02 13:18 anonymous Note Added: 0005553
2004-11-02 13:20 jfudickar Note Added: 0005554
2004-11-02 13:20 jfudickar Status new => feedback
2004-11-02 13:30 bugfinder Note Added: 0005556
2004-11-02 13:31 bugfinder Note Edited: 0005556
2004-11-07 13:45 jfudickar Note Added: 0005584
2004-11-07 15:53 bugfinder Note Added: 0005585
2004-11-08 00:32 jfudickar Note Added: 0005586
2004-11-16 08:33 jfudickar Note Added: 0005640
2004-11-18 15:28 jfudickar Status feedback => assigned
2004-11-18 15:28 jfudickar Assigned To => jfudickar
2004-11-18 15:29 jfudickar Status assigned => feedback
2004-11-18 15:29 jfudickar Issue Monitored: jfudickar
2004-11-19 02:29 anonymous Note Added: 0005674
2004-11-19 02:29 anonymous Note Edited: 0005674
2004-11-19 02:33 anonymous Note Added: 0005675
2004-11-19 03:39 jfudickar Note Added: 0005676
2004-11-19 04:22 anonymous Note Added: 0005677
2004-11-19 05:15 jfudickar Note Added: 0005678
2004-11-19 06:44 bugfinder Note Added: 0005681
2004-11-19 06:50 jfudickar Note Added: 0005682
2004-11-19 06:51 jfudickar Resolution open => fixed
2004-11-19 06:51 jfudickar Fixed in Version => 3.00 BETA 2
2004-11-24 07:28 anonymous Note Added: 0005695
2004-11-24 08:24 jfudickar Status feedback => resolved


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker