Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002279 [JEDI VCL] 00 JVCL Components major always 2004-11-01 02:26 2004-12-20 06:19
Reporter hardnut View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002279: ClipboardCommands of TJvExCustomMaskEdit
Description property ClipBroadCammands has a Defaulf set to all of commands ,but in the Creator ,there is NOT code to set the the ClipboardCommands's initial value to this default value.

then you will get a initial vaue of NONE,if you set the Value to [caCopy..caUndo] in the inspector ,you will get NONE alse--because the Value will not saved in the form file(dfm)
Additional Information     property ClipboardCommands: TJvClipboardCommands read FClipboardCommands
      write SetClipboardCommands default [caCopy..caUndo];


constructor TJvExCustomMaskEdit.Create(AOwner: TComponent);
begin
  {$IFDEF VisualCLX}
  WindowProc := WndProc;
  {$ENDIF VisualCLX}
  inherited Create(AOwner);
  {$IFDEF VisualCLX}
  FCanvas := TControlCanvas.Create;
  TControlCanvas(FCanvas).Control := Self;
  InternalFontChanged := Font.OnChange;
  Font.OnChange := OnFontChanged;
  {$ENDIF VisualCLX}
  FHintColor := Application.HintColor;
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005540)
user72
2004-11-01 06:14

AFAICS, this has already been fixed in CVS (v 1.47)
(0005771)
obones (administrator)
2004-11-30 04:30

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005951)
obones (administrator)
2004-12-20 06:19

This issue is now considered fixed.
Should it not be the case, please open a new one.

- Issue History
Date Modified Username Field Change
2004-11-01 02:26 hardnut New Issue
2004-11-01 06:14 user72 Note Added: 0005540
2004-11-01 06:14 user72 Status new => feedback
2004-11-01 06:14 user72 Issue Monitored: user72
2004-11-30 04:30 obones Note Added: 0005771
2004-12-20 06:19 obones Status feedback => resolved
2004-12-20 06:19 obones Resolution open => fixed
2004-12-20 06:19 obones Assigned To => obones
2004-12-20 06:19 obones Note Added: 0005951
2004-12-20 06:19 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker