Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002290 [JEDI VCL] 00 JVCL Components crash always 2004-11-04 01:23 2004-11-30 04:36
Reporter IanJ View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002290: JvDBGrid bug
Description Drop a table on a form and connect to a table, open the
table. Drop a datasource on a form and connect to table. Drop a JvDBGrid on the form and connect it to the datasource. Go to Options for the grid and set ColumnResize to False. Try and resize the columns. I get a 'grid index out of range' error.

Another way is to drop the components on the form and connect them up but don't open the table. Change ColumnResize to false, *try* and change the column width and then open the table.

Another one, which I don't seem to be able reproduce any more, was to drop a JvDBGrid on a new, clean form, set ColumnResize to false. Clicking on the first column divider (the one after indicator) made the column width expand. Clicking on the column divider for the single data
column (the one to the far right) made the column resize (double each time, i think) several times. The ColLine (the last one, RH divider of rightmost column) also stays greyed sometimes when it's been clicked on with ColumnResize = false until the next time you click on it.

Sorry that that is all bit airy-fairy but it's one of those things that had me sitting here going 'Uhh!?!?' and the only way to find out what was going on was to try again when, of course, it wouldn't do it.

But the first couple of these definitely work every time and hopefully it'll give you enough of a clue.
Additional Information I was asked to provide a sample app. I've included just the dfm as the Upload File only allows a single file. There also isn't any code or anything else involved anyway.
Tags No tags attached.
Attached Files ? file icon Unit1.dfm [^] (1,314 bytes) 2004-11-04 01:23

- Relationships

-  Notes
(0005590)
user72
2004-11-08 05:26

I am not able to reproduce this error with the latest CVS version and D6 Ent. In my case, nothing happens - no resize and no errors.
(0005591)
user72
2004-11-08 05:34

I have to revise that a bit: I can resize the columns at design-time and the first and second column gets the same width (which is an error in and of itself). Still no errors, though.

Could it be because I am using another database engine (ADO - I don't have BDE installed)?
(0005592)
user72
2004-11-08 05:38

I found one issue with dgColumnResize that might have to do with this. Please get the latest version (1.88) from CVS and rebuild the JvDB package to see if your problem is resolved.
(0005595)
anonymous (viewer)
2004-11-09 08:11

There's still a problem. Same setup. Open database, resize columns and all is ok. Turn off ColResize while the table is open and resize and it's the 'grid index out of range' again. Turning it back on and resizing gives an error, but does it.


I rebuilt the JvDBD5D package. I hope that was the right one? You said to rebuild JvDB but I couldn't find one of those and a grep for JvDBGrid only showed up in the JvDBDX series.

HTH
(0005596)
anonymous (viewer)
2004-11-09 08:30

I don't know what's happening here. It seemed a little too familiar to leave it without one more package rebuild. Did that. Now, it doesn't fall over but setting ColumnResize to false has no effect at all. I can still resize the columns. That's one straight out of the box or one hooked up and open or closed.
(0005605)
user72
2004-11-11 10:58

ColumnResize at design-time is allowed (and should be). It should not be allowed at run-time if disabled. Is that how it works now?
(0005606)
user72
2004-11-11 11:00

> You said to rebuild JvDB
The D5 version is called JvDB5R/JvDBD5D, the D6 version is called JvDBD6R/JvDBD6D etc. We call them by their generical name, JvDB, for simplicity.
(0005613)
anonymous (viewer)
2004-11-11 19:49

Thanks for the post. Sorry I didn't get back to you before - it was bedtime here. <g>

I knew about the versioning which is why I used 'JvDBX' in my question, but thanks for the hand-holding anyway. It's much appreciated.

The grid seems to be running very well now. What I found the other day was that I could resize the columns at run-time with Resize set to false.

I'm doing some serious fiddling around this end so it's quite possible that I needed a reboot or recompile of something else. I've been trying to find a problem with a simple component that I'm trying to put on a DBCtrlGrid (the sooner someone brings out a replacement for that piece of $h17, the better. It's been broken since they introduced it - D2? D3? don't remember now - and it hasn't been improved since) and it's refusing to play. After messing around with it for three days it's quite possible that I'd screwed something else.

Many thanks for the fixes and for the update.

Cheers

- Issue History
Date Modified Username Field Change
2004-11-04 01:23 IanJ New Issue
2004-11-04 01:23 IanJ File Added: Unit1.dfm
2004-11-08 05:26 user72 Note Added: 0005590
2004-11-08 05:26 user72 Status new => feedback
2004-11-08 05:34 user72 Note Added: 0005591
2004-11-08 05:38 user72 Note Added: 0005592
2004-11-09 08:11 anonymous Note Added: 0005595
2004-11-09 08:30 anonymous Note Added: 0005596
2004-11-11 10:58 user72 Note Added: 0005605
2004-11-11 11:00 user72 Note Added: 0005606
2004-11-11 19:49 anonymous Note Added: 0005613
2004-11-30 04:36 obones Status feedback => resolved
2004-11-30 04:36 obones Resolution open => fixed
2004-11-30 04:36 obones Assigned To => obones
2004-11-30 04:36 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker