Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002292 [JEDI VCL] 00 JVCL Components minor always 2004-11-04 11:23 2004-12-11 06:22
Reporter Sharky View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002292: TJvCombobox Autocomplete does not work
Description TJvCombobox Autocomplete does not work, it has worked in Beta 1.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005576)
user72
2004-11-05 15:55

Please attach a project (zipped, source-only) to this report that shows the problem. What version of Delphi are you using?

I tested with Delphi 6 - unable to reproduce.
(0005725)
Sharky (reporter)
2004-11-26 18:49
edited on: 2004-11-26 18:50

You can reproduce it this way (1 minute work):

Create a TJvCombobox, add foobar to Items, set AutoCompelte to true.

Start the project.

type foo into the combobox.

Beta 1: the combobox changes the text to foobar.

Beta 2 and current CVS: the text is not changed from foo to foobar.

I'm using Delphi 5.

edited on: 11-26-04 18:50
(0005728)
user72
2004-11-27 08:16

Oh, I see now. The problem is that AutoComplete has a default value of True but it is not set in the constructor, so add:

  {$IFDEF COMPILER5}
  FAutoComplete := True;
  {$ENDIF COMPILER5}

somewhere in TJvCustomComboBox.Create and recompile the package (JvStdCtrls).
(0005780)
obones (administrator)
2004-11-30 04:42

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005866)
user72
2004-12-11 06:22

No reply, so assuming it works with the fix provided

- Issue History
Date Modified Username Field Change
2004-11-04 11:23 Sharky New Issue
2004-11-05 15:55 user72 Note Added: 0005576
2004-11-05 15:55 user72 Status new => feedback
2004-11-26 18:49 Sharky Note Added: 0005725
2004-11-26 18:50 Sharky Note Edited: 0005725
2004-11-27 08:16 user72 Note Added: 0005728
2004-11-30 04:42 obones Note Added: 0005780
2004-12-11 06:22 user72 Status feedback => resolved
2004-12-11 06:22 user72 Resolution open => fixed
2004-12-11 06:22 user72 Assigned To => user72
2004-12-11 06:22 user72 Note Added: 0005866
2004-12-11 06:22 user72 Assigned To user72 =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker