Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002294 [JEDI VCL] 00 JVCL Components major always 2004-11-05 08:13 2004-11-05 13:46
Reporter glchapman View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002294: TJvCustomWideEditor does not accept spaces
Description Typing the space character in a TJvWideEditor appears to have no effect (the caret is not moved). I believe the problem is the test near the beginning of TJvCustomWideEditor.InsertChar:

  if Value > 32 then
  //if Key in [0000032..0000255] then

The commented-out part is what is in TJvCustomEditor, which I assume is correct, so apparently the test should be:

  if Value >= 32
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005575)
AHUser (developer)
2004-11-05 13:46

Thanks.

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2004-11-05 08:13 glchapman New Issue
2004-11-05 13:46 AHUser Issue Monitored: AHUser
2004-11-05 13:46 AHUser Issue End Monitor: AHUser
2004-11-05 13:46 AHUser Status new => resolved
2004-11-05 13:46 AHUser Resolution open => fixed
2004-11-05 13:46 AHUser Assigned To => AHUser
2004-11-05 13:46 AHUser Note Added: 0005575


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker