Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002295 [JEDI VCL] 00 JVCL Components crash always 2004-11-06 06:26 2004-12-11 06:25
Reporter Moskwa View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002295: TJvCustomDBTreeView and Insert new record when DataSet is empty
Description TJvCustomDBTreeView has an error (access violation) when You try to add new record when DataSet is empty. Because Selected is nil and there is exception on Selected.Parent in line AddChildNode(Selected.Parent, True).EditText
Additional Information Change for example in KeyDown procedure :
VK_INSERT:
      if not IsEditing then
      begin
        Sel := Selected;
        if [ssAlt] = Shift then
          //AddChild
          AddChildNode(Selected, True).EditText
        else begin
          //Add
          if Selected<>nil then //this prevent access
                                //violation on Insert first
                                //child when DS is empty
            AddChildNode(Selected.Parent, True).EditText
          else AddChildNode(nil, True).EditText;
        end;
      end;

it will add first item at Root.

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005589)
user72
2004-11-08 05:19

This has already been fixed, AFAICS:

    VK_INSERT:
      if not IsEditing then
      begin
        Sel := Selected;
        if not Assigned(Selected) or ([ssAlt] = Shift) then
          //AddChild
          AddChildNode(Selected, True).EditText
        else
          //Add
          AddChildNode(Selected.Parent, True).EditText;
      end;

The latest CVS file carries this version ID tag:
// $Id: JvDBTreeView.pas,v 1.33 2004/09/01 15:06:36 ahuser Exp $
(0005773)
obones (administrator)
2004-11-30 04:33

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005867)
user72
2004-12-11 06:25

No reply, so assuming it works

- Issue History
Date Modified Username Field Change
2004-11-06 06:26 Moskwa New Issue
2004-11-08 05:19 user72 Note Added: 0005589
2004-11-08 05:19 user72 Status new => feedback
2004-11-30 04:33 obones Note Added: 0005773
2004-12-11 06:25 user72 Status feedback => resolved
2004-12-11 06:25 user72 Resolution open => fixed
2004-12-11 06:25 user72 Assigned To => user72
2004-12-11 06:25 user72 Note Added: 0005867
2004-12-11 06:25 user72 Assigned To user72 =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker