Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002318 [JEDI VCL] 00 JVCL Components minor always 2004-11-16 13:06 2004-12-10 02:48
Reporter korecek View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002318: TJvFormStorage and TJvListView.Items storage (bug)
Description There is not possible to store "TJvListView.Items" through
TJvFormStorage component.

Steps:
1. Create new project
2. Put TJvListView component on a form
3. Put a TJvFormStorage and a TJvAppXMLFileStorage
   components on the form
4. Set "XML" FileName and Location and set AppStoragePath
   properties of the components.
5. Create some Columnus and add some Items and
   SubItems into JvListView and
6. Add "JvListView.Items" into StoredProps of the
   JvFormStorage
7. Finally, compile, run and close application and look at
   your *.XML file. I suppose there is nothing in XML for
   JVCL from 12 of Nov. 2004.
Additional Information I can also upload example in BCB6 when it will be requested.
Tags No tags attached.
Attached Files zip file icon StoreListView.zip [^] (13,021 bytes) 2004-12-01 11:47
zip file icon LVAppImg_Xml.zip [^] (7,892 bytes) 2004-12-02 03:59
zip file icon StoreLVItems.zip [^] (3,682 bytes) 2004-12-02 13:41

- Relationships

-  Notes
(0005642)
jfudickar (developer)
2004-11-16 15:13

Thanks for you description.

But i don't have a eays answer for you :-(

Until now it's not possible.

TListItems will not be stored using the TJvAppStorage by default.

Until now you have to reimplemt the feature like hofi has mentioned.


For me it's not so easy, to decide what to do.

Some possibilities:
1. Do nothing => Not supported => had to be done manually
2. Enhance JvAppStorage.pas to support TListItems => This would mean: include comctrls to the uses of JvAppStorage => NOT Good
3. Enhance JvListView to support the JvAppStorage => Include JvAppStorage to the JvListView.pas file => NOT so bad

Any comments or further ideas welcome.
(0005654)
jfudickar (developer)
2004-11-18 15:01

Fixed an uploaded.

Please have a look on it and give it a try.

Comments are welcome
(0005777)
obones (administrator)
2004-11-30 04:39

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 14 days, we will consider this issue fixed.
(0005783)
korecek (reporter)
2004-11-30 06:59

I have installed version of JVCL from 29.11.2004.

It works pretty fine if there are no preset any data in JvListView
during design time. It works very nice in this case.

If I preset some columnus Items in design time it give me
Acces violation error during the second run of the program (data are
already stored in *.XML file).

Regards
Vaclav
(0005797)
jfudickar (developer)
2004-12-01 02:23

Can you please build an sample application for that.
In my tests it works without problems.
(0005798)
korecek (reporter)
2004-12-01 03:19

Sorry,
at the moment I am not able to upload a zipped file, because
I have got following error:
"The following error was encountered:

Write Error
The system returned:

    (32) Broken pipe
    An error condition occurred while writing to the network.
 Please retry your request. "
???

The file I'd like to upload has size app. 700KB.
I'll try it later.
(0005799)
user72
2004-12-01 08:11

> at the moment I am not able to upload a zipped file
Only upload zipped sources, no binaries please. I believe 700k is way above the limit
(0005800)
korecek (reporter)
2004-12-01 11:55

> Only upload zipped sources, no binaries please. I believe
> 700k is way above the limit
I wanted to upload "exe" application with sources. Sources are BCB6 but it
should not be problem to convert it to Delphi I guess.
There is also included message box image which I got after second start
of application. (*.XML file did not exist during its first start)
(0005803)
jfudickar (developer)
2004-12-01 23:42

Could you also include a screenshot of the opened application and the created xml-file. I'm not a BCB-User :-)
(0005804)
korecek (reporter)
2004-12-02 04:00

> Could you also include a screenshot of the opened application and the
> created xml-file.

Done
(0005809)
obones (administrator)
2004-12-02 13:43

Hi Jens

I just did a test with the very latest CVS snapshot, both in BCB and Delphi.
The bug shows up when starting the application with an existing XML file.

I attached the same example converted to Delphi, you should be able to see the bug with the included XML file.
(0005810)
jfudickar (developer)
2004-12-02 14:22

Thanks Olivier,

it was the faster way.

The problem is, i can't see anything.

I know now that it seems to be not a point of the appstorage code (for me). It seems to be that the av is only raised, when the load happens in the formcreate/formshow process.
If you deactivate the active property and load the contents manually by button, there is no problem.

So maybe you have an other idea? I didn't know from where the av comes.

Greetings
Jens
(0005811)
jfudickar (developer)
2004-12-02 14:30

Hopefully found it (thanks to MadExcept).

The error was in TJvListView.WmAutoSelect

The WParam Object was no longer in the list, so it raises an exception.

I will upload the changes now. Please have a look and give us a feedback.
(0005815)
korecek (reporter)
2004-12-02 22:41

Hi,
my tests are without AV now. ;-)

Thanks
(0005816)
jfudickar (developer)
2004-12-02 23:14

Great News.

So i think we will wait one week again, and then close the case.
(0005822)
obones (administrator)
2004-12-03 13:19

Just tested it here, works fine in C++ Builder 6 and Delphi 6 with the latest CVS.

- Issue History
Date Modified Username Field Change
2004-11-16 13:06 korecek New Issue
2004-11-16 15:13 jfudickar Issue Monitored: jfudickar
2004-11-16 15:13 jfudickar Note Added: 0005642
2004-11-18 15:01 jfudickar Note Added: 0005654
2004-11-18 15:05 jfudickar Status new => assigned
2004-11-18 15:05 jfudickar Assigned To => jfudickar
2004-11-18 15:05 jfudickar Status assigned => feedback
2004-11-30 04:39 obones Note Added: 0005777
2004-11-30 06:59 korecek Note Added: 0005783
2004-12-01 02:23 jfudickar Note Added: 0005797
2004-12-01 03:19 korecek Note Added: 0005798
2004-12-01 08:11 user72 Note Added: 0005799
2004-12-01 11:47 korecek File Added: StoreListView.zip
2004-12-01 11:55 korecek Note Added: 0005800
2004-12-01 23:42 jfudickar Note Added: 0005803
2004-12-02 03:59 korecek File Added: LVAppImg_Xml.zip
2004-12-02 04:00 korecek Note Added: 0005804
2004-12-02 13:41 obones File Added: StoreLVItems.zip
2004-12-02 13:43 obones Note Added: 0005809
2004-12-02 14:22 jfudickar Note Added: 0005810
2004-12-02 14:30 jfudickar Note Added: 0005811
2004-12-02 22:41 korecek Note Added: 0005815
2004-12-02 23:14 jfudickar Note Added: 0005816
2004-12-03 13:19 obones Note Added: 0005822
2004-12-10 02:48 jfudickar Status feedback => resolved
2004-12-10 02:48 jfudickar Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker