Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002325 [JEDI VCL] 00 JVCL Components feature N/A 2004-11-19 08:07 2004-11-29 06:58
Reporter anonymous View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002325: JvZoom misses properties
Description The missing ones are: Anchors, Align, Visible, Constraints.
These would be better if possible: zoom percent (instead of zoom level), custom glyph (instead of crosshair).
Repaint issue when changing Active.
Add procedure ZoomInAtPoint(x, y).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005685)
user72
2004-11-22 02:06

> Repaint issue when changing Active.
What issue?

> Add procedure ZoomInAtPoint(x, y).
What should it do?
(0005686)
user72
2004-11-22 03:12

I've committed an updated unit to CVS with the proposed changes. The ZoomInAt method works like this:

If Enabled is true, the cursor is moved to the specified point and a capture is done in the control. As soon as the user moves the mouse, the capture is changed. If Enabled is false, a capture is done at the specified location but moving the mouse does not change the capture.

In short, if Enabled is false, you must control the capture area with code as the users mouse movement doesn't change anything.

I also added a CrossHairPicture property. To use, assign an image to it and set CrossHair to true. The CrossHairPicture is always drawn transparently (if supported by the picture format)
(0005754)
user72
2004-11-29 06:58

Since no reply, assuming that the changes were satisfactory

- Issue History
Date Modified Username Field Change
2004-11-19 08:07 anonymous New Issue
2004-11-22 02:06 user72 Note Added: 0005685
2004-11-22 02:06 user72 Status new => feedback
2004-11-22 03:12 user72 Note Added: 0005686
2004-11-22 03:13 user72 Issue Monitored: user72
2004-11-29 06:58 user72 Status feedback => resolved
2004-11-29 06:58 user72 Resolution open => fixed
2004-11-29 06:58 user72 Assigned To => user72
2004-11-29 06:58 user72 Note Added: 0005754


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker