Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002335 [JEDI VCL] 00 JVCL Components minor always 2004-11-23 08:13 2005-11-22 09:19
Reporter marcgeldon View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 2.10
Summary 0002335: JvDBTreeView
Description If you insert a new node. And on this node you'll insert a child node you get an exception.

I use the component with ADO and MS SQL. The problem is the following: the new node does not get it's "FMasterValue". If you assign the MasterValue in the AfterPost of the used dataset with lines like this:

----
If Assigned(JvDBTreeView.Selected) then
  TJvDBTreeNode(JvDBTreeView.Selected).SetMasterValue(ADScategoriescategoryid.AsInteger);
----

it will work. But I think this should be fixed in the TJvDBTree source.


Best wishes,

Marc Geldon
(marc.geldon --at-- proitsystems.de)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005710)
user72
2004-11-25 09:51

Have you tried this with JVCL 3? IIRC, this has already been fixed there.
(0005779)
obones (administrator)
2004-11-30 04:42

Please try with the latest zip files and tell us if the problem is fixed. These files are available here:

http://jvcl.sf.net/daily/ [^]
http://jcl.sf.net/daily/ [^]

If we don't hear from you in the next 7 days, we will consider this issue fixed.
(0005868)
user72
2004-12-11 06:26

No reply, so assuming it works
(0007954)
marcgeldon (reporter)
2005-09-22 03:53

Hello!

Sorry that it took me so long so answer. I've tested it now. This issue is really fixed!


Best wishes,

Marc Geldon
(PRO IT SYSTEMS)
(0008139)
obones (administrator)
2005-11-22 09:19

As per original poster's comments

- Issue History
Date Modified Username Field Change
2004-11-23 08:13 anonymous New Issue
2004-11-23 08:17 marcgeldon Issue Monitored: marcgeldon
2004-11-23 21:44 Robert Rossmair Reporter anonymous => marcgeldon
2004-11-25 09:51 user72 Note Added: 0005710
2004-11-25 09:51 user72 Status new => feedback
2004-11-30 04:42 obones Note Added: 0005779
2004-12-11 06:26 user72 Status feedback => resolved
2004-12-11 06:26 user72 Resolution open => fixed
2004-12-11 06:26 user72 Assigned To => user72
2004-12-11 06:26 user72 Note Added: 0005868
2004-12-11 06:26 user72 Assigned To user72 =>
2005-09-22 03:53 marcgeldon Status resolved => feedback
2005-09-22 03:53 marcgeldon Resolution fixed => reopened
2005-09-22 03:53 marcgeldon Note Added: 0007954
2005-11-22 09:19 obones Status feedback => resolved
2005-11-22 09:19 obones Resolution reopened => fixed
2005-11-22 09:19 obones Assigned To => obones
2005-11-22 09:19 obones Note Added: 0008139


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker