Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002336 [JEDI VCL] 02 Installation feature always 2004-11-24 07:30 2004-11-26 01:05
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002336: Doesnt detect delphi 2k5.
Description For some reason it doesnt detect my version of delphi 2005 to install.
Additional Information Most of my other components have compiled up on d7 settings, Im thinking JCL/JVCL will too, however, at the moment the nice installer doesnt detect d2k5.

The trial is not sufficient to install either, as it doesnt have the commandline compilers. So would need precompiled stuff :(
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005697)
AHUser (developer)
2004-11-24 10:37

I do not have D2k, yet. And so I cannot make the required changes to the installer.
The installer will never support a trial version because of the missing command line compiler.
(0005698)
bugfinder (reporter)
2004-11-24 13:12

I realised this, but I wanted to point it out just in case. As Im finding that Im struggling to get the jvcl to compile with packages anyway.
(0005699)
mattis000102 (reporter)
2004-11-24 22:54

Got my copy of 2k5 yesterday, haven't tried installing JVCL yet (haven't tried much at all actually). What does the JVCL installer need to know, is it something that we can dig out and then give you the information so that you can add support for it?

I will look into the code of the installer this evening (10 hours from now) and see what I can do.
(0005700)
AHUser (developer)
2004-11-25 03:03
edited on: 2004-11-25 03:05

At the moment the Installer (CVS) should detect BDS 3.0 and so it meight work, but it is not tested because with the trial version it is impossible to test the dcc32.exe calls.
And the installer requires an installed JCL 1.93 (CVS) what prevents me from debugging the installer downt the dcc32.exe calls.

bearbeitet am: 11-25-04 03:05
(0005701)
anonymous (viewer)
2004-11-25 05:22

The latest cvs detects the d2k5, but isnt seeing the jcl on it, and the jcl installer doesnt detect the d2k5 either.
(0005702)
AHUser (developer)
2004-11-25 05:31

The JCL installer is not my part ;-)

I'm currently working on the installer. After installing the JCL by hand it found out that the JVCL installer detects the D2k as C++Builder version. And further more the Borland Project Group file (.bpg) has been changed to an xml file .bdsgroup which the JVCL installer ignores at the moment so no JVCL packages are available in the Installer's package selection list.
(0005703)
anonymous (viewer)
2004-11-25 05:40

I installed the jcl by hand too, but the jvcl installer didnt detect it :(
(0005705)
AHUser (developer)
2004-11-25 08:54

You must add the jcl\source;jcl\source\common;jcl\source\windows directories to the library path list in Tools/Options. That is what the installer normally does. After that the updated JVCL installer detects the JCL (by finding jcl\source\common\JvBase.pas)

I have committed a new version of installer that should work. But I was not able to test the compile process because there is no dcc32.exe shipped with D2k Trial.
(0005717)
AHUser (developer)
2004-11-26 01:05

JVCL Installer now detects D2k.

- Issue History
Date Modified Username Field Change
2004-11-24 07:30 anonymous New Issue
2004-11-24 10:37 AHUser Note Added: 0005697
2004-11-24 13:12 bugfinder Note Added: 0005698
2004-11-24 22:54 mattis000102 Note Added: 0005699
2004-11-25 03:03 AHUser Note Added: 0005700
2004-11-25 03:05 AHUser Note Edited: 0005700
2004-11-25 05:22 anonymous Note Added: 0005701
2004-11-25 05:31 AHUser Note Added: 0005702
2004-11-25 05:40 anonymous Note Added: 0005703
2004-11-25 08:54 AHUser Note Added: 0005705
2004-11-26 01:05 AHUser Status new => resolved
2004-11-26 01:05 AHUser Resolution open => fixed
2004-11-26 01:05 AHUser Assigned To => AHUser
2004-11-26 01:05 AHUser Note Added: 0005717
2004-11-30 04:31 jpsc Issue Monitored: jpsc


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker