Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002346 [JEDI VCL] 00 JVCL Components minor always 2004-11-28 13:42 2005-01-17 11:49
Reporter dippen View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002346: TJvTrayIcon stops receiving WM_CONTEXTMENU after BalloonHint
Description I'm running WinXP PRO SP2. I use TJvTrayIcon, and before the first call to BalloonHint the context menu appears correctly. After I've displayed a balloon hint, the context menu doesn't appear on right clicks any more. This is because the TJvTrayIcon.WindProc don't receive any WM_CONTEXTMENU message after the BalloonHint method has been called. I realize that it might be a Windows issue rather than a JVCL issue.
Additional Information I've fixed the problem by making the following changes in TJvTrayIcon.WindProc:

WM_RBUTTONDOWN: begin
                  DoMouseDown(mbRight, ShState, Pt.X,Pt.Y);
                  DoContextPopup(Pt.X, Pt.Y);
                end;

....

Commented out the entire case WM_CONTEXTMENU, NIN_KEYSELECT:
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006079)
obones (administrator)
2005-01-04 08:13

I'm using JvTrayIcon here and I don't have such problem. I'm using XP Home SP1.

Please try with the latest CVS version (1.35) of that file and let us know.
Alternatively, you could wait until the next release is available, sometime before the end of January.
(0006178)
obones (administrator)
2005-01-17 06:14

The RC1 release is available, please test it and let me know how this goes.
Once again, I have no such problem here.
(0006181)
anonymous (viewer)
2005-01-17 11:26

I've installed v1.35 and now it works. The file with the problem was v1.34. From my point of view the case is closed! Thanks alot for the help.
(0006182)
dippen (reporter)
2005-01-17 11:29

Sorry, forgot to login before... The previous note was mine.
(0006183)
obones (administrator)
2005-01-17 11:49

As indicated by the poster, this is now resolved

- Issue History
Date Modified Username Field Change
2004-11-28 13:42 dippen New Issue
2004-11-28 13:43 dippen Issue Monitored: dippen
2004-11-30 04:45 obones Status new => assigned
2004-11-30 04:45 obones Assigned To => obones
2005-01-04 08:13 obones Note Added: 0006079
2005-01-04 08:13 obones Status assigned => feedback
2005-01-17 06:14 obones Note Added: 0006178
2005-01-17 11:26 anonymous Note Added: 0006181
2005-01-17 11:29 dippen Note Added: 0006182
2005-01-17 11:49 obones Status feedback => resolved
2005-01-17 11:49 obones Resolution open => fixed
2005-01-17 11:49 obones Note Added: 0006183


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker