Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002357 [JEDI VCL] 00 JVCL Components crash always 2004-12-02 08:07 2005-02-15 17:48
Reporter DelTexley View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002357: JvAppIniStorage / JvFormStorage problem when 2nd form is auto-create.
Description I get a crash in Delphi 5 with the beta 3. Create a form and drop a JvAppIniFileStorage and JvFormStorage on it. Set AutoFlush and AutoReload to true. Set a DefaultSection and Filename. On the JvFormStorage set the AppStorage and AppStoragePath. Create a second form and drop a JvFormStorage on it, set the AppStorage to point at the JvAppIniFileStorage on the main form and set the AppStoragePath. Drop a button to call the Secondform.ShowModal to display it and set the form to auto-create. Compile and run, exit without diaplaying the second form and you'll get a crash. If you display the second form the crash will not occur. I traced the problem down to where it tries to write the section for the second form and it crashes trying to access the first parameter to being stored. Apparently there are some values that are undefined until the Show/ShowModal is processed.
Additional Information
Tags No tags attached.
Attached Files zip file icon FormPlacementTest2.zip [^] (4,438 bytes) 2004-12-05 13:07

- Relationships

-  Notes
(0005805)
jfudickar (developer)
2004-12-02 09:16

Could you upload this sample. It's faster for me :-)
(0005806)
jfudickar (developer)
2004-12-02 09:17

Could you upload this sample. It's faster for me :-)
(0005832)
jfudickar (developer)
2004-12-05 13:08

Sorry, i can't reproduce it.

Please try my attached sample. It's build as you have described. No error for me.
(0005979)
jfudickar (developer)
2004-12-22 02:23

Reminder sent to: DelTexley

Hi,

i'm waitng for your response.

Greetings
Jens Fudickar
(0006134)
DelTexley (reporter)
2005-01-13 12:58

Sorry about the delay getting back to you on this. It appears that the problem only occurs with projects that I migrate from the older version (v2.1) of Jedi or RxLib, and even then only in some cases.

If I create a new project the problem doesn't occur.
(0006135)
jfudickar (developer)
2005-01-13 14:07

So is it okay for you to close this item?
(0006392)
obones (administrator)
2005-02-04 04:03

Note that without any answers from you in the next 7 days, we will consider this issue fixed
(0006503)
jfudickar (developer)
2005-02-15 17:42

No further comments -> fixed

- Issue History
Date Modified Username Field Change
2004-12-02 08:07 DelTexley New Issue
2004-12-02 09:16 jfudickar Note Added: 0005805
2004-12-02 09:17 jfudickar Note Added: 0005806
2004-12-05 13:07 jfudickar File Added: FormPlacementTest2.zip
2004-12-05 13:08 jfudickar Note Added: 0005832
2004-12-05 13:08 jfudickar Issue Monitored: jfudickar
2004-12-22 02:21 jfudickar Status new => feedback
2004-12-22 02:23 jfudickar Note Added: 0005979
2005-01-05 03:09 jfudickar Status feedback => assigned
2005-01-05 03:09 jfudickar Assigned To => jfudickar
2005-01-05 03:10 jfudickar Status assigned => feedback
2005-01-13 12:58 DelTexley Note Added: 0006134
2005-01-13 14:07 jfudickar Note Added: 0006135
2005-02-04 04:03 obones Note Added: 0006392
2005-02-15 17:42 jfudickar Status feedback => resolved
2005-02-15 17:42 jfudickar Resolution open => fixed
2005-02-15 17:42 jfudickar Note Added: 0006503
2005-02-15 17:48 jfudickar Status resolved => feedback
2005-02-15 17:48 jfudickar Resolution fixed => reopened
2005-02-15 17:48 jfudickar Status feedback => resolved
2005-02-15 17:48 jfudickar Fixed in Version => 3.00 RC 1
2005-02-15 17:48 jfudickar Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker