Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002364 [JEDI VCL] 00 JVCL Components crash always 2004-12-06 16:44 2004-12-19 04:25
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002364: TJvPluginManager
Description With Beta 2 & latest daily build, PluginManager is crashing when unloading dlls. When it executes unloadlibrary, it never returns & the CPU debug display shows & dialog re too many exceptions. It appears to be Index = 0 related. I can copy multiple copies of the same dll, with different names & successfully unload count -1 down to 1, but when unloading 0 it crashes

 PlgI := FPluginInfos.Items[Index];
  PlgI.PlugIn.Free;
  UnloadLibrary(PlgI.PluginKind, PlgI.Handle);
  PlgI.Free;
  FPluginInfos.Delete(Index);

Thanks
Bill
Additional Information
Tags No tags attached.
Attached Files zip file icon sCControlCenter.zip [^] (219,935 bytes) 2004-12-12 11:46

- Relationships

-  Notes
(0005848)
user72
2004-12-09 12:35

Have you tried the demo in jvcl\examples\JvPlugin\1SimplePlugin (set InstanceCount to 0 in the DLL project, compile it and make copies of the result)?

When I run the demo, I don't get any errors.
(0005858)
anonymous (viewer)
2004-12-10 15:27

I wish it were simple to give you a easy test case. The simple demo works. I changed instance count to 0, made multiple copies of the dll w different names, added an unloadplugin menu to UI and works as expected. My plugins heavily use COM/ActiveX. I had no problems w ver2 or ver3 beta1. I know it's not much to go on. I'll try to generate a simple example.
Thanks
Bill
(0005861)
user72
2004-12-11 03:55

There doesn't seem to be any changes since the beta 2 release that could affect behaviour (it's mostly cleanup and adding missing contributors etc).

Makes me think that maybe your project has changed and that's why it doesn't work anymore, i.e the problem is on your side?
(0005872)
anonymous (viewer)
2004-12-12 11:50

I would generally agree. I have two different apps that had been working prior to beta2. It could very well be latest changes in jcl or other jvcl components. I've gutted (removed all app specific functionality) from a simple app and uploaded. Using one copy of the simple ddl demonstrates problem when unloading via menu item. BTW I'm running D7 (build 8.1) under XP SP2
Thanks,
Bill
(0005874)
user72
2004-12-13 04:48

Have a look at 0002375. Maybe that's the reason?
(0005879)
anonymous (viewer)
2004-12-13 16:15

Peter, not quite sure how it would be related. Using simple plugin dll, it does not have an OnCreate function. I tried the plugin with both oldcreate order as well as new

Thanks
Bill
(0005905)
anonymous (viewer)
2004-12-17 08:24

Hi all,

this is exactly the problem I have. The domos work fine. When I copy my plugin into the demo directory it works. Then I created a new project: just a Listbox, a Button and the PluginManager, copied the demo plugin and my plugin into the directory and ...crash! So it can't be the plugin, because that works with the simple demo and the error also turns up when using the demo-plugin. But I found no code in the demo that I don't have in my app. And: The error also appears with an old version of JVCL (that was why I updated). Any Ideas ???

Sascha
(0005909)
user72
2004-12-18 03:05

Do you have sharemem as the first unit in the uses of the project? Only thing I can think of that could be different...
(0005912)
anonymous (viewer)
2004-12-18 03:51

Hey Peter3, you'r king of the day! I only studied the unit over and over, but didn't look at the project file.

Thank you
Sascha
(0005915)
user72
2004-12-18 04:04

Glad that resolved it! Can we close this issue now?
(0005922)
anonymous (viewer)
2004-12-18 12:24

It worked for me as well. Thank you very much for the great support. Yes I think we can close
Bill
(0005929)
user72
2004-12-19 04:25

OK, problem solved

- Issue History
Date Modified Username Field Change
2004-12-06 16:44 anonymous New Issue
2004-12-09 12:35 user72 Note Added: 0005848
2004-12-09 12:35 user72 Status new => feedback
2004-12-10 15:27 anonymous Note Added: 0005858
2004-12-11 03:55 user72 Note Added: 0005861
2004-12-12 11:46 anonymous File Added: sCControlCenter.zip
2004-12-12 11:50 anonymous Note Added: 0005872
2004-12-13 04:48 user72 Note Added: 0005874
2004-12-13 16:15 anonymous Note Added: 0005879
2004-12-17 08:24 anonymous Note Added: 0005905
2004-12-18 03:05 user72 Note Added: 0005909
2004-12-18 03:51 anonymous Note Added: 0005912
2004-12-18 04:04 user72 Note Added: 0005915
2004-12-18 12:24 anonymous Note Added: 0005922
2004-12-19 04:25 user72 Status feedback => resolved
2004-12-19 04:25 user72 Resolution open => fixed
2004-12-19 04:25 user72 Assigned To => user72
2004-12-19 04:25 user72 Note Added: 0005929
2004-12-19 04:25 user72 Assigned To user72 =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker