Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002376 [JEDI VCL] 02 Installation minor always 2004-12-13 11:40 2005-01-17 06:08
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.00 BETA 2
Summary 0002376: Installation error
Description I got these files on sourceforge:
JVCL300BETA2Complete.zip
JCL1.93-Build1722a.zip
which i suppose that are the latest non-cvs versions.

I begun installing JVCL, I was asked to install JCL first, i did it and restarted JVCL installer.

After some wizzards i got this:

[Compiling: JvCryptD5R.bpl]
Borland Delphi Version 13.0 Copyright (c) 1983,99 Inprise Corporation
D:\1Delphi\Componentes\JediVCL\run\JvZlibMultiple.pas(35) Fatal: File not found: 'JclZLib.dcu'

** error 1 ** deleting "D:\Delphi5\Delphi5\Projects\Bpl"\JvCryptD5R.bpl

** error 1 ** deleting CompilePackages
Additional Information I have Delphi 5 Enterprise
version 5.0 (Build 5.62)
(without any upgrade or Service Pack)

running in Windows 2000 Advanced Server
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002341closedAleksey Kudinov Installation stopped looking for JclZlib.pas in JvCrypt/JvZlibMultiple.pas 

-  Notes
(0005877)
user72
2004-12-13 13:52

Please search old bug reports before posting new ones.
(0006061)
anonymous (viewer)
2005-01-02 10:32

Although this issue's status is "resolved" I still get the same error using
JVCL300BETA2COMPLETE and JCL1.94-Build1758 (clean install).
(0006062)
AHUser (developer)
2005-01-02 15:35

Have a look at the time stamps of the JVCL300BETA2COMPLETE and the bugfix.

Use a daily snapshot to overcome this issue.
(0006078)
obones (administrator)
2005-01-04 08:07

In other words:

Don't use a recent JCL (Code Library) with an old JVCL (Jedi VCL).
JCL 1.94 was released AFTER JVCL 3B2 and as such contains changes that will only be taken into account when the next version of JVCL 3 (called RC1) will be released.

- Issue History
Date Modified Username Field Change
2004-12-13 11:40 anonymous New Issue
2004-12-13 13:52 user72 Relationship added duplicate of 0002341
2004-12-13 13:52 user72 Duplicate ID 0 => 2341
2004-12-13 13:52 user72 Status new => resolved
2004-12-13 13:52 user72 Resolution open => duplicate
2004-12-13 13:52 user72 Assigned To => user72
2004-12-13 13:52 user72 Note Added: 0005877
2004-12-13 13:52 user72 Assigned To user72 =>
2005-01-02 10:32 anonymous Status resolved => feedback
2005-01-02 10:32 anonymous Resolution duplicate => reopened
2005-01-02 10:32 anonymous Note Added: 0006061
2005-01-02 15:35 AHUser Note Added: 0006062
2005-01-04 08:07 obones Status feedback => resolved
2005-01-04 08:07 obones Resolution reopened => fixed
2005-01-04 08:07 obones Assigned To => obones
2005-01-04 08:07 obones Note Added: 0006078
2005-01-04 08:07 obones Assigned To obones =>
2005-01-04 08:07 obones Duplicate ID 2341 => 0
2005-01-17 06:08 obones Status resolved => closed
2005-01-17 06:08 obones Fixed in Version => 3.00 RC 1


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker