Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002384 [JEDI VCL] 03 Donations feature N/A 2004-12-14 16:28 2004-12-20 13:37
Reporter korecek View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002384: Delphi into BCB6 conversion (JvUIB, JvZoom, JvWndProcHook)
Description The uploaded zip files contains example conversion from Delphi into BCB6.
Additional Information 1. Regarding JvUIB:
   a) it's for IB6 (open source) and there is also a script for database
      creation.
   b) database cannot be connected in design time (in IDE) because there are
      used relative path direction in DatabaseName property (JvUIBDataBase).
      Reason: EXE is stored in "..\..\bin" directory ;-)
2. Regarding JvWndProcHook:
   there are some little differences in comparison Delphi code.
  
Tags No tags attached.
Attached Files zip file icon JvUIB.zip [^] (58,163 bytes) 2004-12-14 16:30
zip file icon JvZoom.ZIP [^] (6,330 bytes) 2004-12-14 16:31
zip file icon JvWndProcHook.ZIP [^] (5,179 bytes) 2004-12-14 16:32

- Relationships

-  Notes
(0005964)
obones (administrator)
2004-12-20 13:37

Thanks for all that, this is now in CVS.

Should you want to make other examples, please take these requests into account:

- Do not put any B6, C6 or version related suffixes in any of the filenames. This is because the demos compile with BCB5 in 99% of the cases.
- Ensure that the "Compile with runtime packages" is NOT checked, and that Dynamic RTL (linker page) is NOT check
- Ensure that no relative directories are in the options.
- Ensure that the output paths are set correctly (that was already the case in your demos)
- Clean up the XML in the bpr file so that the LIBRARIES, PACKAGES and SPARELIBS nodes are empty. Once cleaned up, ensure it compiles and DO NOT save it.


Once again, thanks for your effort.

Cheers
Olivier

- Issue History
Date Modified Username Field Change
2004-12-14 16:28 korecek New Issue
2004-12-14 16:30 korecek File Added: JvUIB.zip
2004-12-14 16:31 korecek File Added: JvZoom.ZIP
2004-12-14 16:32 korecek File Added: JvWndProcHook.ZIP
2004-12-20 06:57 obones Status new => assigned
2004-12-20 06:57 obones Assigned To => obones
2004-12-20 13:37 obones Status assigned => resolved
2004-12-20 13:37 obones Resolution open => fixed
2004-12-20 13:37 obones Note Added: 0005964


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker